mail news messages do not display

VERIFIED INVALID

Status

SeaMonkey
MailNews: Message Display
P3
normal
VERIFIED INVALID
19 years ago
14 years ago

People

(Reporter: asa, Assigned: Scott MacGregor)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

19 years ago
The Problem:  When you click on a mail or news header the message is not
displayed in the message pane.  The spinner will start up and spin indefinitely
with no message appearing in the message pane.  The output on the console stalls
at:

ThreadPaneController.isCommandEnabled
threadTree = [object XULTreeElement]
ThreadPaneController.isCommandEnabled
ThreadPaneController.isCommandEnabled
ThreadPaneController.isCommandEnabled
ThreadPaneController.isCommandEnabled
threadTree = [object XULTreeElement]

I have discovered that if I minimize the mail news window after clicking on the
message header and give focus to the console window this output shows up almoast
immediately:

Document: Done (8.84 secs)
WEBSHELL+ = 11
Document: Done (2.8 secs)

and when I return to the mail news window the message is displayed.
After palying with it some more I noted that if I return to the mail news window
before the second "Document: Done" message appears then the message is still not
loaded (ther is a hole in the window where the message should be.) I can repeat
this example with the same results. The only difference will be the times
displayed.  The first instance of the "Document: Done" message will have a time
that is as long (or real close) as the lenght of time that I left the mail news
window maximized after I clicked on a header but before I minimized the mail
news window.  I can also stretch the length of the second "Document: Done" time
by returning to the mail news window before the second "Document: Done" message
appears.  If I sit on the maximized mail news window for say 3 minutes and then
minimize it and give focus back to the console it will almost immediately
display the "Document: done" message with a time of about 3 minutes and
maximizing the mail news window will show the loaded message.

So to summarize:  If I click on a header in mail or news I can wait for 5
minutes for ir to display and it won't.  But as soon as I minimize the mail news
window and give focus to the console it will spit out the message  "Document:
Done (302.84 secs)| WEBSHELL+ = 11 | Document: Done (2.8 secs) and the message
will be displayed in the mail news message pane.

Expected Behavior: User should be able to click on a message header triggering
mozilla to display the message in teh message pane.

This testing was done using nightly pre-compiled binaries from 12/12 and 12/13
(both the zipped and the installer versions) on Windows 98 running on a P90 wiht
32 MB RAM.  Additional testing with similar results was done on a P100 with 16MB
RAM.

Updated

19 years ago
Assignee: phil → mscott

Comment 1

19 years ago
Scott was looking into this, but I don't see the open bug anymore. Did you fix it?

Comment 2

19 years ago
cc: sspitzer who was talking to asa about this.

Comment 3

19 years ago
fyi, Phil:

One bug (where the message NEVER displays in the message pane) is:
http://bugzilla.mozilla.org/show_bug.cgi?id=20546

Another bug (where the message SOMETIMES does not display in the msg pane after
usage) is: http://bugzilla.mozilla.org/show_bug.cgi?id=20653
(Reporter)

Updated

19 years ago
Status: NEW → RESOLVED
Last Resolved: 19 years ago
Resolution: --- → INVALID
(Reporter)

Comment 4

19 years ago
Further investigation:  After a full cleansing of mozilla from my system and
importing a newly created 4.x profile into 12/14 win32 zipped version build I am
unable to re-create this problem.  I am marking this bug invalid.  If I am able
to re-create the bug I will re-open or file a new bug (not sure the protocol on
this).  Thanks to Seth and Lisa for thier help with this issue.

Updated

19 years ago
Status: RESOLVED → VERIFIED

Comment 5

19 years ago
thanks for the update, asa.  I'll go ahead and mark this verified as invalid.
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.