If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Disabling slider.snapMultiplier doesn't seem effective.

RESOLVED WONTFIX

Status

()

Core
XUL
RESOLVED WONTFIX
14 years ago
5 years ago

People

(Reporter: Shanmu, Unassigned)

Tracking

({testcase})

Trunk
DEC
OSF/1
testcase
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

14 years ago
User-Agent:       Mozilla/5.0 (X11; U; OSF1 alpha; en-US; rv:1.5a) Gecko/20030827
Build Identifier: Mozilla/5.0 (X11; U; OSF1 alpha; en-US; rv:1.5a) Gecko/20030827

I am using mozilla 1.4 on a Tru64 UNIX machine.
I wanted to disable the snapping behaviour. 
So I set the snapMultiplier to "0" in the unix.js as follows

pref("slider.snapMultiplier", 0);

I restarted the browser, but still I see the snapping behavior.
This makes the scrolling an ugly experience. 
Mozilla 1.4RC2 works fine. Some changes that were checked in
between RC2 and the actual 1.4 release has caused this regression.

Reproducible: Always

Steps to Reproduce:
1.Start the browser
2.Load a scrollabe page
3.Scroll down the mouse to see the snapping 
(even after setting the pref("slider.snapMultiplier", 0); )

Actual Results:  
The scrollbar snaps back and forth

Expected Results:  
The snapping should have disabled.
(Reporter)

Comment 1

14 years ago
One more thing is that the scrollbar keeps snapping 
to the top of the page as I scroll downward straight. 

Comment 2

14 years ago
Are there contradictory settings in user.js or prefs.js?
Asking since I thought this was a user_pref, not a "pref"...
What happens if you remove the line entirely from unix.js?
(Reporter)

Comment 3

14 years ago
I can't see anything contradictory in the pref files.
I commented the whole line in the unix.js and all.js, 
but snapping  continues. I set the following in 
my prefs.js  (under my .mozilla)
user_pref("slider.snapMultiplier",0)
But the same behavior.

With the same profile everything seems to be fine with 
Mozilla 1.3, 1.4b, 1.4RC2. 
However debugging the code I saw that the x, y values
of the slider are set to some negative values when my 
slider is in the middle of the window.

(ladebug) 
[1] stopped at [virtual nsresult nsSliderFrame::HandleEvent(class
nsIPresContext*, struct nsGUIEvent*, enum nsEventStatus*):476 0x300036c6868]
    476       nscoord pos = isHorizontal ? aEvent->point.x : aEvent->point.y;
(ladebug) p aEvent->point
struct nsPoint {
  x = -6600;
  y = -2196;
}
(ladebug) file
nsSliderFrame.cpp

It starts with a positive value. The second time it reaches this code
it is all negative. 
->toolkit
Assignee: other → jag
Component: Layout → XP Toolkit/Widgets
QA Contact: ian → jrgm
I'm seeing this on Deerpark and suite. Windows XP.
If I restart suite, then it takes effect (snap behavior stops)
Keywords: testcase

Updated

9 years ago
Assignee: jag → nobody
Is this still an issue ?
Status: UNCONFIRMED → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.