unable to find a dynamic address when it changes while having a page opened

RESOLVED DUPLICATE of bug 162871

Status

()

defect
RESOLVED DUPLICATE of bug 162871
16 years ago
16 years ago

People

(Reporter: Peter6, Assigned: darin.moz)

Tracking

Trunk
x86
Windows 2000
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

16 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.5a) Gecko/20030728 Mozilla Firebird/0.6.1
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.5a) Gecko/20030728 Mozilla Firebird/0.6.1

If a site that uses a DYNDNS address, that changes while you are looking at it,
Moz browsers are unable to find the new IP number (IE does not have that problem).
The only way to find the dyndns new IP is by closing ALL the browser windows
that are open and start with a new window.

Reproducible: Always

Steps to Reproduce:
1.
2.
3.



Expected Results:  
Let Moz look for the new IP address as soon as the old one is not valid anymore.
Right - this is an old implementation issue/bug (I'm sure there are a million
bugs filed on this already, with a few valid ones remaining open).

However, this /might/ be something Darin addressed with his DNS service rewrite,
but I'm not sure.

I'll go look for the older bug in the meantime.
bug 151929 explores our DNS caching / TTL implementation and suggestions for the
future.

Give it a whirl, it just /might/ be what you're looking for ;-)

Comment 3

16 years ago
-> Netwerk
Assignee: general → darin
Component: Browser-General → Networking
QA Contact: general → benc
using the offline/Online switch should fix this

*** This bug has been marked as a duplicate of 162871 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.