input type=button (or submit) does not accept text alignment

RESOLVED DUPLICATE of bug 138403

Status

()

Core
Layout: Form Controls
--
enhancement
RESOLVED DUPLICATE of bug 138403
15 years ago
15 years ago

People

(Reporter: Peter6, Unassigned)

Tracking

Trunk
x86
Windows 2000
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

15 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.5a) Gecko/20030728 Mozilla Firebird/0.6.1
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.5a) Gecko/20030728 Mozilla Firebird/0.6.1

In the followinf form:

<form>
 <input type="button" style="text-align:left;width:200px" value="not left">
 <input type="submit" style="text-align:left;width:200px" value="also not left">
</form>

does NOT left-align the text in the "input" (IE does, W3C says it should).
In some cases, with a number of buttons below eachother it looks real bad if the
values with different lenght are center aligned.
Most seem to work around it by using a picture with text i/o the input button,
but I find that rather inefficient (more loads, more bytes).


Reproducible: Always

Steps to Reproduce:
1.
2.
3.

Comment 1

15 years ago
The submit portion of this at least is definitely a dupe of bug 138403, though
that doesn't say anything about non-submit buttons. Note David Baron's comments
about whether the CSS spec actually says anything about form controls obeying
text-align.
Whether a button submits or not does not affect the way it's laid out.  And no,
W3C says nothing whatsoever about what applying text-align to a replaced element
should do.

*** This bug has been marked as a duplicate of 138403 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.