Closed Bug 217753 Opened 21 years ago Closed 21 years ago

scrolling up and down causes a portion of some lines of text to disappear

Categories

(SeaMonkey :: General, defect)

Sun
Solaris
defect
Not set
normal

Tracking

(Not tracked)

RESOLVED DUPLICATE of bug 171282

People

(Reporter: tagonzo, Unassigned)

References

()

Details

Attachments

(4 files)

User-Agent:       Mozilla/5.0 (X11; U; SunOS sun4u; en-US; rv:1.4) Gecko/20030701
Build Identifier: Mozilla/5.0 (X11; U; SunOS sun4u; en-US; rv:1.4) Gecko/20030701

On the page http://www.mozilla.org/, scroll down slow to medium pace.  Look for
lines of text with a missing a row of pixels.  Now hightlight a word in that
line, the whole line gets redrawn and text looks correct.  Also, switch to a new
tab, then return, all text is now drawn properly.

I have seen this on many web pages, and with all version of mozilla that I've
used. 1.2.1, 1.3, 1.4

Also, I've seen this on Linux and Solaris, but not Windows or Mac OS X.  Seem to
be associate with GTK or X11.

I will attach snapshots for examples.

Reproducible: Always

Steps to Reproduce:
1. go to web page http://www.mozilla.org/
2. scroll down at slow to medium speed
3.

Actual Results:  
text does not get redrawn correctly

Expected Results:  
during scrolling, all text should look normal.
Is this Solaris-only?  I've never run into this on Linux...
I see it on Solaris almost everyday.  I have seen it on Linux, but don't use it
often.  I will try it again on Linux and post my results.
OS: SunOS → Solaris
I have attached examples of this issue on lunix. (Redhat 9, all updates
installed, GTK+ 1.2.10, GTK2 2.2.1, mozilla 1.4)

My Sun systems is an Ultra 10, Solaris 8, a recent Recommended Patch cluster,
GTK+ 1.2.10, mozilla 1.4)

Again, I don't see this on the Windows version or the Mac OSX version.
Attachment #130604 - Attachment description: text after scrolling → text after scrolling on solaris
Attachment #130605 - Attachment description: text after highlighted → text after highlighted on solaris
I've had this same problem using Firebird in Windows XP.  Seen this happen since
0.6, now using the 10/15 build of 0.7.  This only happens when scrolling slowly,
not when I use page down/up.  It also only happens on my laptop which has a
custom DPI setting in Windows' Display properties.  I don't get this problem on
my desktop which uses the default DPI.  When I change the DPI to the default on
my laptop the text seems to paint correctly, but I prefer the higher DPI setting.
This is a well-known problem. There are several bug reports about it; see bug 
134942, the single-pixel tracking bug.

I believe the problem is commonly seen with solaris because sun hardware
normally operates at a resolution which makes the bug particularly visible. A
workaround is to go into Preferences->Appearance->Fonts and set "display
resolution" to 96dpi.

*** This bug has been marked as a duplicate of 171282 ***
Status: UNCONFIRMED → RESOLVED
Closed: 21 years ago
Resolution: --- → DUPLICATE
Kenneth Herron wrote:
> I believe the problem is commonly seen with solaris because sun hardware
> normally operates at a resolution which makes the bug particularly visible

This isn't Sun-hardware specific, just SOlaris/Xsun defaults to 90DPI unless the
hardware defaults to something else or the admin configures a different default.
Roland Mainz wrote:
>This isn't Sun-hardware specific, just Solaris/Xsun defaults to 90DPI unless the
>hardware defaults to something else or the admin configures a different default.

Actually I have seen this on RedHat Linux as well.  I attached jpegs of both
Linux and Solaris with this behavior.

Will setting the dpi to 96 correct the Linux Mozilla as well?

Also, I just set my Solaris Mozilla to 96dpi, and I still get the missing pixel
effect when scrolling.

Is this fixed in Mozilla 1.5?  I think I'll upgrade to it soon.
It appears that setting the dpi to 96, and restarting Solaris Mozilla 1.4, has
resolved the scrolling issue.  I guess the dpi is not updated dynamically.
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.

Attachment

General

Creator:
Created:
Updated:
Size: