[RFE] Stop forcing me to migrate 4.X profiles

VERIFIED DUPLICATE of bug 18118

Status

SeaMonkey
Installer
P3
enhancement
VERIFIED DUPLICATE of bug 18118
19 years ago
14 years ago

People

(Reporter: Jerry Baker, Assigned: selmer (gone))

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

19 years ago
Did it not occur to the developers of the installer that someone may not want to
migrate their 4.x profiles? I don't appreciate having to wait while Mozilla
migrates my 200+MB 4.X profile every time I do a clean install of Mozilla. I
just have to go right in and delete it all everytime. I am shocked that Mozilla
and Netscape would hijack someone's hard drive in this fashion.

Updated

19 years ago
Severity: normal → enhancement

Updated

19 years ago
Assignee: ssu → selmer

Comment 1

19 years ago
This part of the profile manager initialization code.  Reassigning to Steve
Elmer.
(Assignee)

Updated

19 years ago
Status: NEW → ASSIGNED
Target Milestone: M16
(Assignee)

Comment 2

19 years ago
Currently, we're living with a compromise.  After things settle down a little
we're going to revisit the copying aspect of migration.  Ideally, migration can
be done in-place and you will cease to be annoyed by it happening
automatically.  I'll leave this open until the migration decision gets made.
(Reporter)

Comment 3

19 years ago
What is "done-in-place"? I will continue to be annoyed if Mozilla does not
relinquish control to me. I do not like software that decides these things for
me.

Comment 4

19 years ago
I completely agree.  I avoid going through migration as much as possible because
I don't want it to copy my mail files.  I have a lot of mail files, and if I
wanted them copied, I'd copy them myself.  In addition, migration doesn't work
for everyone -- it sometimes hangs on NFS file systems, see bug 19163.  What
happens if there isn't enough space on the current hard drive for an extra copy
of a user's entire set of mail folders?

What about the users (I am one) who may want different prefs in mozilla vs.
their 4.5 prefs?  They're not the same program; why would a user's chosen prefs
necessarily be the same?

If the user is going to be forced to migrate, there should at least be a "don't
copy my mail files (except maybe Inbox)" option.  But it would be better to have
a "don't migrate at all" option.
(Assignee)

Updated

19 years ago
Status: ASSIGNED → RESOLVED
Last Resolved: 19 years ago
Resolution: --- → DUPLICATE
(Assignee)

Comment 5

19 years ago
*** This bug has been marked as a duplicate of 18118 ***

Updated

19 years ago
Status: RESOLVED → VERIFIED

Comment 6

19 years ago
checked bug 18118 - it is same bug
(Reporter)

Comment 7

16 years ago
Mass removing self from CC list.
(Reporter)

Comment 8

16 years ago
Now I feel sumb because I have to add back. Sorry for the spam.
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.