bugs count charts are not displayed for products with spaces in the name

VERIFIED FIXED in Bugzilla old

Status

()

Bugzilla
Bugzilla-General
P1
minor
VERIFIED FIXED
20 years ago
5 years ago

People

(Reporter: Jay Ball, Assigned: Don McCasland)

Tracking

unspecified
Bugzilla old

Details

Attachments

(1 attachment)

(Reporter)

Description

20 years ago
bugzilla will not display a bug chart for any products with spaces in the name.
this is because of: <img src="data/mining/name with spaces.gif"> in the
report.cgi generated html.

a simple fix is to insert this after line 468 in report.cgi:

        $image =~ s/ /%20/g;

Updated

20 years ago
Status: NEW → ASSIGNED

Comment 1

19 years ago
Reassigning to dmose@mozilla.org, who now has front-line responsibility for
all Bonsai and Bugzilla bugs.

Comment 2

19 years ago
Reassigning back to me.  That stuff about me no longer being the front-line
person responsible for Bugzilla and Bonsai turned out to be short-lived.
Please pardon our confusion, and I'm very sorry about the spam.

Comment 3

19 years ago
Another way to patch it would be to use url_quote; this may handle additional
characters other than space that need to be escaped (though the only issue at
our site, as with the reporter, is spaces in the name).  Here is the patch I
made at our site (diff -u):

        $img->gif (*IMAGE, \@data);
        close IMAGE;

+        ### randall 2000-01-04  n.b. url-quote affects slash as well as space.
+        $imageUrl = $dir . "/" . url_quote($file) . ".gif";
        print <<FIN;
-<img src="$image">
+<img src="$imageUrl">
 <br clear=left>
 <br>
 FIN

Comment 4

19 years ago
Error in previous addition to comments; the second added line should be:
+        my $imageUrl = $dir . "/" . url_quote($prodname) . ".gif";

Apologies for the double comment (diff'ed the wrong revision first time).

Updated

19 years ago
Status: NEW → ASSIGNED
Priority: P4 → P2

Comment 5

18 years ago
Created attachment 5798 [details] [diff] [review]
patch to fix this bug, very similar to ideas mentioned in comments previously
I just ran into this on my site, too.  I just cvs updated again this morning. :)  
This looks pretty obvious, any reason it hasn't been checked in yet?

Comment 7

18 years ago
Because I'm a loser?

Upping priority to P1, which is where I will hopefully first look for things to
do when I actually have a few cycles to spend on Bugzilla stuff.
Priority: P2 → P1

Comment 8

18 years ago
tara@tequilarista.org is the new owner of Bugzilla and Bonsai.  (For details,
see my posting in netscape.public.mozilla.webtools,
news://news.mozilla.org/38F5D90D.F40E8C1A%40geocast.com .)
Assignee: terry → tara
Status: ASSIGNED → NEW

Comment 9

18 years ago
Don--looks like this is already has a patch.  Be the patch, Luke.
Assignee: tara → donm
*** Bug 36678 has been marked as a duplicate of this bug. ***
(Assignee)

Comment 11

18 years ago
I'm reviewing the patch now.
Status: NEW → ASSIGNED
(Assignee)

Comment 12

18 years ago
ok, checked in.  closing bug.
Status: ASSIGNED → RESOLVED
Last Resolved: 18 years ago
Resolution: --- → FIXED

Comment 13

18 years ago
Looks good!  Marking Verified.
Status: RESOLVED → VERIFIED
*** Bug 36678 has been marked as a duplicate of this bug. ***
Moving to Bugzilla product
Component: Bugzilla → Bugzilla-General
Product: Webtools → Bugzilla
QA Contact: matty
Target Milestone: --- → Bugzilla old
Version: other → unspecified
QA Contact: matty_is_a_geek → default-qa
You need to log in before you can comment on or make changes to this bug.