Closed Bug 217803 Opened 21 years ago Closed 19 years ago

Custom mail notification sound very crackling

Categories

(Thunderbird :: Mail Window Front End, defect)

x86
Linux
defect
Not set
normal

Tracking

(Not tracked)

RESOLVED DUPLICATE of bug 68804

People

(Reporter: marcus, Assigned: mscott)

References

Details

The custom mail notification sound on Linux is very crackling and sounds very
overdrived. This seems to depend on the bitrate, I will make some tests and post
the most worse bitrates. The same samples played with the Windows version sound
very clear and good.
I am not shure if it is a good idea to post the samples to this database, I will
set up a website with some examples, if this is helpful.

System:
Suse Linux 8.2 with Creative Audigy Player
i'm seeing similar behaviour here as well.  linux gtk2, self-built from 20030908
cvs.  if i enter in a "custom .wav file" for mail notifications, and click the
preview button, the sound seems to play fine, except that it is followed by a
sharp, high-pitched crackling/screeching noise.  i'm using alsa (emu10k1 driver)
built into kernel 2.6.0-test5.  playing the same file using alsa (via 'aplay'),
using OSS-emulation (via 'play'), and through ESD (via 'esdplay') causes no such
problem.
QA Contact: asa
Same problem on Redhat 9. It would be nice if there was a way to specify in
Linux what program to use to play the sound.
*** Bug 231931 has been marked as a duplicate of this bug. ***
I have had the same problems under Fedora Core 2. The sound I was using was a
default KDE 3.2.2 sound file /usr/share/sounds/KDE_Beep_Yo.wav: RIFF
(little-endian) data, WAVE audio, Microsoft PCM, 8 bit, mono 11127 Hz. A loud
pop was played before the file was played. I have converted the sound using
Audacity to RIFF (little-endian) data, WAVE audio, Microsoft PCM, 16 bit, mono
44100 Hz (output of `file' command), which has resolved the problem (the sound
plays smoothly, no pops or cracks or hissing)
I was not having the "click" sound problem until today, when I upgraded from
Linux kernel 2.6.11.11 to 2.6.12, which also upgraded ALSA from 1.0.8 to
1.0.9rc2.  I then upgraded ALSA to 1.0.9b just to make sure I had the most
recent ALSA drivers.  I had the same problem with both 1.0.9rc2 and 1.0.9b.

I get an audible click every time the new mail notification sound is played,
right at the beginning.  If I use "aplay", or "esdplay" to play the sound file
myself, I hear no click, even when I use "esdplay" to send the WAV file to the
same ESD daemon that the mail client started.

Therefore, there must be something wrong with the way that the mail client sends
the sound to ESD.

This occurs identically in both Thunderbird and Mozilla Mail.

Also, as a sidenote, it would be nice to allow users to configure the choice of
sound playing tool.  For example, I would prefer to use "aplay" instead of ESD.
Dupe of bug 68804?
*** Bug 298330 has been marked as a duplicate of this bug. ***
Talked with people on moznet they agree.

*** This bug has been marked as a duplicate of 68804 ***
Status: NEW → RESOLVED
Closed: 19 years ago
Resolution: --- → DUPLICATE
I'm not certain this bug is a dupe of bug 68804.  The facts are:

1. I was not hearing any click until moving from kernel 2.6.11.9 to kernel
2.6.12 (and 2.6.12.1 and 2.6.12.2).

2. I was not hearing any click until moving from ALSA 1.0.8 to ALSA 1.0.9rc2
(part of 2.6.12.2) and ALSA 1.0.9b (self-upgraded).

3. Playing my "new mail" sound (new_mail.wav) works fine using "aplay".  No
crackle at all.

4. Playing new_mail.wav works fine using "esdplay", even when playing through
the same esd daemon that Mozilla mail started.  No crackle.


Based on these facts, it seems that Mozilla Mail is not sending the WAV file to
the daemon correctly, and the latest ALSA drivers appear to have brought the bug
to the surface.
You need to log in before you can comment on or make changes to this bug.