clicking on the topmost drop down list in a file dialog box (when saving downloads) freezes Mozilla

RESOLVED EXPIRED

Status

--
critical
RESOLVED EXPIRED
15 years ago
13 years ago

People

(Reporter: nina, Unassigned)

Tracking

Trunk
x86
Windows ME

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

15 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Win 9x 4.90; en-US; rv:1.5b) Gecko/20030821
Build Identifier: Mozilla/5.0 (Windows; U; Win 9x 4.90; en-US; rv:1.5b) Gecko/20030821

When saving attachments from emails or just downloading files from the internet,
a file-dialog appears (as expected).
If you click on the Drop-Down list in the file dialog, the browser hangs and has
to be closed "brutally" with the task manager. I waited about 5 minutes, it was
not a sleeping hard drive causing a delay. Other dialog-boxes in other programs
work fine, just not in Mozilla!

When I first installed a 1.5b version of mozilla, my ZoneAlarm asked me about
some programs to access the internet, I never heard of, when I tried to save a
downloaded file and - at the same moment - hung up. Now, I have denied access
for those programs. They identified as some "windows maintaining" programs.
MAYBE (I'm not sure!) they're amongst those programs here:
(ssdpsrv.exe? stimon.exe? sucatreg.exe?)
Is there ANY reason why another program should connect to the net if you
download a file?

Reproducible: Always

Steps to Reproduce:
1. Make something that opens a save-file dialog (clicking a download link,
saving an attachment...)
2. Click the topmost drop-down list (with folders, drives, and so on)
3. Watch the program freeze OR an ominous program is asking your firewall to
pass - and hangs

Actual Results:  
Program freezed.

Expected Results:  
Show the content of the drop-down list and let me select a folder.

I was running ZoneAlarm 3.7.202.
When I first tried to download a file with a 1.5b Mozilla version, an exe
program I couldn't recognize asked for permission. It seemed to be some kind of
windows maintenance programs.

Comment 1

15 years ago
I´m runnin an older version of ZoneAlarm, and there is no reason for something
popping up to be allowed to connect to the internet.
If I open a pdf file, Acrobat asks wether it should look for updates, but
doesn´t crash, if I disallow.
Seems you have installed some spyware, maybe together with Windows Maintaining
Programs, or Downloadmanagers.

Search google for ssdpsrv, and do the same with stimon, sucatreg.

Ssdpsrv.exe is the file that starts the UPnP server on WindowsME boxes. ... 

http://www.google.com/search?q=ssdpsrv&sourceid=mozilla-search&start=0&start=0&ie=utf-8&oe=utf-8
Ssdpsrv.exe in WindowsME. ... By connecting to a computer running
Ssdpsrv you are able to crash the Ssdpsrv server
http://cert.uni-stuttgart.de/archive/bugtraq/2001/10/msg00133.html

http://www.google.com/search?hl=en&lr=&ie=UTF-8&oe=utf-8&q=stimon&btnG=Google+Search
http://www.google.com/search?hl=en&lr=&ie=UTF-8&oe=utf-8&q=sucatreg&btnG=Google+Search
(Reporter)

Comment 2

15 years ago
Sorry, this was an ME bug, not Win98.
I Always get caught in the bug-entry page where you just cannot enter "Windows
ME", so I chose Win98 automatically, because it's most related to ME compared to
the other Windows OSs.
Maybe they're a LOT more bug-reports with a wrong Win-OS selected.
But it's also in the Navigator-Info, so just take a very, very close look at it.

Just Now, I'm using this version of Mozilla:	
Mozilla 1.5b
Mozilla/5.0 (Windows; U; Win 9x 4.90; en-US; rv:1.5b) Gecko/20030908

I found out something new about this bug.

Only when I start Mozilla for the _first_ time, clicking on the "Desktop",
"Eigene Dateien" buttons on the left side of the Folder-View or on the drop-Down
list on top of it makes my Mozilla hang up.

After shooting it up with ctrl-alt-del(there's no other way to close it then),
and restarting Mozilla, the big Buttons (Desktop, etc..) and the drop-down list
works as supposed!

And still I think it's a Mozilla-bug, because every other Application behaves
well at this point. It's _just_ Mozilla.

To me, this sounds like a very, very deeply buried, complicated bug, and at
first sight, it looks like it's Windows-Bug, but it's more like a bug that may
only be visible running winME.

Clueless...
OS: Windows 98 → Windows ME

Comment 3

15 years ago
Is this still open?
Product: Browser → Seamonkey
Nina, is this still a problem with a current build/Release on Windows ME ? 
This is an automated message, with ID "auto-resolve01".

This bug has had no comments for a long time. Statistically, we have found that
bug reports that have not been confirmed by a second user after three months are
highly unlikely to be the source of a fix to the code.

While your input is very important to us, our resources are limited and so we
are asking for your help in focussing our efforts. If you can still reproduce
this problem in the latest version of the product (see below for how to obtain a
copy) or, for feature requests, if it's not present in the latest version and
you still believe we should implement it, please visit the URL of this bug
(given at the top of this mail) and add a comment to that effect, giving more
reproduction information if you have it.

If it is not a problem any longer, you need take no action. If this bug is not
changed in any way in the next two weeks, it will be automatically resolved.
Thank you for your help in this matter.

The latest beta releases can be obtained from:
Firefox:     http://www.mozilla.org/projects/firefox/
Thunderbird: http://www.mozilla.org/products/thunderbird/releases/1.5beta1.html
Seamonkey:   http://www.mozilla.org/projects/seamonkey/
This bug has been automatically resolved after a period of inactivity (see above
comment). If anyone thinks this is incorrect, they should feel free to reopen it.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → EXPIRED
You need to log in before you can comment on or make changes to this bug.