Scrolling with mouse wheel doesn't paint text properly

RESOLVED INVALID

Status

Core Graveyard
GFX: Gtk
RESOLVED INVALID
15 years ago
9 years ago

People

(Reporter: Teemu Voipio, Assigned: blizzard)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

15 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.5a) Gecko/20030827 Mozilla Firebird/0.6.1
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.5a) Gecko/20030827 Mozilla Firebird/0.6.1


On some sites, on of them http://www.gnome.org/gnome-office/, when scrolling up
and down with mouse wheel, some of the text doesn't appear properly and some
link underlinings continue too far.

This does NOT happen when scrolling with keyboard or the scrollbar.

Reproducible: Always

Steps to Reproduce:
1. Go to Gnome office site
2. Scroll up and down with wheel.


Actual Results:  
Part of the text is missing, until another program is focused, another tab
selected, or page is scrolled with the scrollbar or keyboard so as to force a
repaint.

Expected Results:  
Page should display properly.

I'm using custom build on Gentoo with gnome2 support (gtk2 widgets),
and Gecko/20030827. I could not reproduce this with official 0.6.1 build.
(Reporter)

Comment 1

15 years ago
This problem and a minor alignment bug where normal text moved few pixels right
after an italic or bold block where both fixed when I recompiled the exact same
version with one change: No Xft(2.0) support.

Additional thing to note is that my Xft is actually version 2.1.0.

I also found that the problematic build (and "official" gtk2+xft firebird build)
draw correctly when either smooth-scrolling was enabled or mouse scroll line
count was set high or low enough. My original setting that caused the problem was 5.

So I believe that the problem actually exists in Xft support.
(Reporter)

Comment 2

14 years ago
Ok, found the cause. It was a problem in Xfree mga drivers, offscreen pixmaps
not working correctly. Seems that Mozilla's one of the few apps that actually
cause the bug to become visible.

Disabling offscreen pixmaps in Xfree XAA fixes the problem.

So it's not a mozilla bug after all. Sorry about trouble. In any case, searching
for similar bugs, found a few which look like they might be dupes. At least
#190289 seems to have similar symptoms.
(Assignee)

Comment 3

14 years ago
Marking INVALID.  Thanks!
Status: UNCONFIRMED → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → INVALID
Product: Core → Core Graveyard
You need to log in before you can comment on or make changes to this bug.