Javascript is allowed to disable right-click context menu

VERIFIED DUPLICATE of bug 86193

Status

()

Core
DOM: Core & HTML
--
enhancement
VERIFIED DUPLICATE of bug 86193
14 years ago
14 years ago

People

(Reporter: Kevin DeGraaf, Unassigned)

Tracking

Trunk
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

14 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.4b) Gecko/20030507
Build Identifier: Mozilla/5.0

Web authors, via JavaScript, are allowed to disable the user's use of the
right-click context-sensitive menu.  This is an obvious flaw.  My web browser
should respect *my* wishes, not capitulate to the desires of the web author. 
Please add a checkbox in the Preferences -> Advanced -> Scripts & Plugins ->
"Allow scripts to..." list to turn off this behavior.

Reproducible: Always

Steps to Reproduce:
1. Go to a retarded page such as http://www.kazaalite.tk/.
2. Attempt to right-click the page, or a hyperlink.
3. Observe brain-damage.

Actual Results:  
Began to fume at (1) **** page designers and (2) Mozilla.

Expected Results:  
Opened the context menu as normal.

Comment 1

14 years ago
Please observe some better language in a public forum such as this.

*** This bug has been marked as a duplicate of 86193 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → DUPLICATE

Comment 2

14 years ago
v
Severity: minor → enhancement
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.