Drop down selections and textarea contents are not saved using Save Form Info in Form Manager

RESOLVED WONTFIX

Status

()

Toolkit
Form Manager
--
enhancement
RESOLVED WONTFIX
15 years ago
10 years ago

People

(Reporter: Webmaster33, Unassigned)

Tracking

Trunk
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

15 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.5a; MultiZilla v1.5.0.0i) Gecko/20030718
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.5a; MultiZilla v1.5.0.0i) Gecko/20030718

Seems Drop down selections and textarea contents are not saved using Save Form Info.
Did anybody else experienced this?

Reproducible: Always

Steps to Reproduce:
1. Select down drop form item or fill textarea with text
2. use Edit/"Save Form Info" menu item
3. Open the page in new window
4. use Edit/"Fill in Form" menu item

Comment 1

15 years ago
Confirmed in 2003102404 on Windows
Status: UNCONFIRMED → NEW
Ever confirmed: true
Summary: Drop down selections and textarea contents are not saved using Save Form Info → Drop down selections and textarea contents are not saved using Save Form Info in Form Manager

Comment 2

14 years ago
Radio buttons aren't saved either.
(Using Mozilla 1.8a2 - 20040616)

Comment 3

13 years ago
Confirmed in 20041217 on Windows XP.
(Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7.5) Gecko/20041217)
Assignee: dveditz → nobody

Comment 4

13 years ago
*** Bug 319967 has been marked as a duplicate of this bug. ***
Severity: normal → enhancement
OS: Windows XP → All
Hardware: PC → All
I would rather like to narrow this wish to only textarea.  On one hand, I don't see any advantage to remember selector selections.  On the other hand, I don't see how saved selector selection would be presented.

For the second point, think of this:
while we could display a box under text input to represent past inputs, how is it possible to show that once in the past I've selected choice #1 in a selector and choice #5 in the same selector a little later in the past?

If you're to say that the selector is selected automatically, I will disagree because user might not be able to know the default choice assigned by web designer.

Comment 6

13 years ago
(In reply to comment #5)
> I would rather like to narrow this wish to only textarea.  On one hand, I don't
> see any advantage to remember selector selections.  On the other hand, I don't
> see how saved selector selection would be presented.
> 
> For the second point, think of this:
> while we could display a box under text input to represent past inputs, how is
> it possible to show that once in the past I've selected choice #1 in a selector
> and choice #5 in the same selector a little later in the past?
> 
> If you're to say that the selector is selected automatically, I will disagree
> because user might not be able to know the default choice assigned by web
> designer.
> 

As far as I know, the options under Edit > Fill in Form and Edit > Save Form Data are only triggered whenever you explicitly select those options -- ie: these are NOT login memorization, nor automatically prefilling forms on page load.

I would imagine these functions are designed to quicken form entry like a developer / QA guy in Bugzilla who's only debugging a specific build for a specific OS - that person could select the OS dropdown and the build / trunk / version / etc then choose Save Form Info...  If the person need to report several bugs, "Fill In Form" would automatically prepopulate the information that never changes, leaving only the specific bug details to fill in.
Filter on "Nobody_NScomTLD_20080620"
QA Contact: tpreston → form-manager

Updated

10 years ago
Component: Form Manager → Form Manager
Product: Core → Toolkit
QA Contact: form-manager → form.manager
There's no longer any meaningful UI to allow selecting specifically-stored values for these kinds of elements, and the functionality seems marginally useful at best.
Status: NEW → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.