Provide option to delete selected mail from POP server

RESOLVED DUPLICATE of bug 47297

Status

MailNews Core
Networking: POP
--
enhancement
RESOLVED DUPLICATE of bug 47297
15 years ago
10 years ago

People

(Reporter: Mike Coppins, Assigned: (not reading, please use seth@sspitzer.org instead))

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

15 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.5b) Gecko/20030827
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.5b) Gecko/20030827

Due to the latest virus doing the rounds, I'm receiving 5 virus-infected email
attachments every hour.  I have Mozilla configured not to auto download mails
bigger than 25KB.  I then have to manually flush out my mailbox using telnet:110
or webmail.

IMO, there should be an option to delete a specific mail from the server.  This
option probably shouldn't also delete the mail locally.

This feature would save me a great deal of time :-)  (I'm a modem user)



Reproducible: Always

Steps to Reproduce:
1.
2.
3.

Comment 1

15 years ago
I like that idea. Confirming.
Status: UNCONFIRMED → NEW
Ever confirmed: true
Summary: suggestion: provide option to delete selected mail from POP server → Provide option to delete selected mail from POP server

Comment 2

15 years ago
Would be a great enhancement of Mozilla Mail.
'Delete messages from server when they are deleted or moved from Inbox' doesn't
work for you?

Comment 4

15 years ago
> 'Delete messages from server when they are deleted or moved from Inbox' doesn't
> work for you?

the RFE seems to be the opposite -- delete remotely without deleting locally

And if I understand it correctly, delete mail without having first downloaded it
at all.
OS: Windows 2000 → All
Hardware: PC → All
(Reporter)

Comment 5

15 years ago
Comment 4 has what I'm saying correctly.

To explain it a bit more -

I'm on a modem connection, I don't like waiting for huge spam HTML emails, or
virus-attached emails to download.

My configuration deletes mails off the server immediately.  I then have the "do
not download messages larger than xKB" option enabled, set to 25KB.  This means
that all messages >25KB are left on the server and not deleted, and so they
accumulate.

To stop them accumulating, I use another mail client (YAM - http://www.yam.ch/ ~
emulating AmigaOS on my Windows box), which does have the feature, or I use
webmail, or telnet:110 to the server.
(Reporter)

Comment 6

15 years ago
Created attachment 134314 [details]
example of a mail client (YAM)'s mail download system

Added screenshot of a mail client called YAM's interface to download mails that
require attention (due to say a configuration that says "don't automatically
download mails that fall into this criteria").

Comment 7

15 years ago
Isn't this bug a dupe of bug 47297? Adding the flexibility from that bug should
enable you to do the things you want.
(Reporter)

Comment 8

15 years ago
Yep, sounds like it.

Comment 9

15 years ago
Yes, the hack Christian provided in bug 47297 does exactly what this bug
requests, in my understanding. Mike, you are the reporter of this bug, mark it
as a duplicate or a dependent.
(Reporter)

Comment 10

15 years ago
Hmm, bizarre.  I thought this bug /had/ been verified as a duplicate.

Whoops.  :-)


*** This bug has been marked as a duplicate of 47297 ***
Status: NEW → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → DUPLICATE
Product: MailNews → Core
Product: Core → MailNews Core
You need to log in before you can comment on or make changes to this bug.