Closed Bug 21789 Opened 20 years ago Closed 20 years ago

Two '.' in file:// name produces 'unknown content type' dialog

Categories

(Core :: Networking, defect, P3)

x86
Windows NT
defect

Tracking

()

VERIFIED FIXED

People

(Reporter: 3jrgm, Assigned: gagan)

References

()

Details

Using WinNT 1999121408, when I enter a 'file:' with more than one '.'
in the filename (e.g., 'file:///c|/foo.bar.html') I receive a dialog box:

  | You are about to download a file of type application/x-unknown-content-type
  |
  | This file is unrecognized by Netscape. You can save it or open it with
  | another application.

Also, this message is displayed in the console window:

  | DocLoaderFactory: Unable to create ContentViewer for command=view,
  | content-type=application/x-unknown-content-type

[Yes, I know: 'Who the heck uses two periods in a _Windows_ filename?' ;-) ]
Forgot to add: I checked this as an http:// URL
(e.g., 'http://www.foo.com/foo.bar.html') and it loads correctly.
Maybe, just maybe some code is searching for the first, not the last . in a
filename to find the FileExtension.
*** Bug 22417 has been marked as a duplicate of this bug. ***
cc'ing law and valeski for their insite on this. Who does the file extension
guess work and where? This is a bug in that area.
*** Bug 21828 has been marked as a duplicate of this bug. ***
*** Bug 22459 has been marked as a duplicate of this bug. ***
Status: NEW → RESOLVED
Closed: 20 years ago
Resolution: --- → FIXED
fix checked in 12/23/99 7:11 pm pac time
verified
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.