Closed Bug 217892 Opened 16 years ago Closed 9 years ago

Problem canceling news-messages when using non-ASCII-characters in long names ("From:"- Header)

Categories

(MailNews Core :: Networking: NNTP, defect)

x86
Windows XP
defect
Not set

Tracking

(Not tracked)

RESOLVED DUPLICATE of bug 390721

People

(Reporter: Andre.Helbig, Unassigned)

Details

(Keywords: qawanted)

User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.4) Gecko/20030624
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.4) Gecko/20030624

Normally I use a quite long name in newsgroups, which is
André "THamTHon" Helbig and Andre.Helbig@fem.tu-ilmenau.de as Emailadress.

When I post a message with these values I get the follwing "From"-line in my
news-article:

From: =?ISO-8859-1?Q?=22Andr=E9_=5C=22THamTHon=5C=22_Helbig=22?=
 <Andre.Helbig@fem.tu-ilmenau.de>

(The From-line is wrapped in 2 lines)

If I try to cancel this Message I get "This message does not appear to be from
you..." 

If I use a shorter name with non-ASCII-characters or a longer name without
non-ASCII-charcters, this problem does not occur. 

For example: "André Helbig" results in 

From: =?ISO-8859-1?Q?Andr=E9_Helbig?= <Andre.Helbig@fem.tu-ilmenau.de>

as the From-line. 

If I use a very long name without non-ASCII-Characters the From-Line is also
not wrapped and i can normally cancel the message. 


Reproducible: Always

Steps to Reproduce:
1. Use a long Name with non-ASCII-Characters like "André "THamTHon" Helbig" in
your Identity
2. Post a message to a newsgroup
3. Try to cancel this message

Actual Results:  
You get an error-message that the message does not appear to be from you and the
message cannot be canceled.

Expected Results:  
I think Mozilla should cancel the message ;)
Product: MailNews → Core
This is an automated message, with ID "auto-resolve01".

This bug has had no comments for a long time. Statistically, we have found that
bug reports that have not been confirmed by a second user after three months are
highly unlikely to be the source of a fix to the code.

While your input is very important to us, our resources are limited and so we
are asking for your help in focussing our efforts. If you can still reproduce
this problem in the latest version of the product (see below for how to obtain a
copy) or, for feature requests, if it's not present in the latest version and
you still believe we should implement it, please visit the URL of this bug
(given at the top of this mail) and add a comment to that effect, giving more
reproduction information if you have it.

If it is not a problem any longer, you need take no action. If this bug is not
changed in any way in the next two weeks, it will be automatically resolved.
Thank you for your help in this matter.

The latest beta releases can be obtained from:
Firefox:     http://www.mozilla.org/projects/firefox/
Thunderbird: http://www.mozilla.org/products/thunderbird/releases/1.5beta1.html
Seamonkey:   http://www.mozilla.org/projects/seamonkey/
still the same problem in thunderbird 1.0.6 :(
sorry for the spam.  making bugzilla reflect reality as I'm not working on these bugs.  filter on FOOBARCHEESE to remove these in bulk.
Assignee: sspitzer → nobody
This issue still not fixed in 2.0.4.
WFM on Linux 2.0.0.15pre, with name  =?ISO-8859-1?Q?Joshua_Cranmer=D8?= . Soliciting further requests for confirmations.
Actually, not sure whether or not it works, since Giganews appears not to allow canceling. But no error-message pops up, which is what the OP explicitly mentioned.
Keywords: qawanted
Filter on "Nobody_NScomTLD_20080620"
QA Contact: stephend → networking.news
I just checked this issue in 2.0.0.17 again. It still doesn't allow canceling of messages, if the from-Field is in the format, which is described above.
(In reply to comment #8)
> I just checked this issue in 2.0.0.17 again. It still doesn't allow canceling
> of messages, if the from-Field is in the format, which is described above.

Do you get an error message, though?
Yes.. I get an Error-Message, that the Posting does not appear to be from me and that i am not allowed to cancel this posting.
Product: Core → MailNews Core
duping forward to confirmed bug 390721
Status: UNCONFIRMED → RESOLVED
Closed: 9 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 390721
You need to log in before you can comment on or make changes to this bug.