"Get mail" button label should be "Get messages" (to be more appropriate for News and Feed accounts)

RESOLVED FIXED in Thunderbird 25.0

Status

Thunderbird
Mail Window Front End
--
trivial
RESOLVED FIXED
15 years ago
5 years ago

People

(Reporter: Peter Richter, Assigned: alta88)

Tracking

({polish})

Trunk
Thunderbird 25.0
polish

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

15 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.5b) Gecko/20030830 Firebird/0.6.1+
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.5b) Gecko/20030830 Firebird/0.6.1+

"Get messages" is more appropriate then "Get mail" for News accounts IHMO. So
when i select a News account or a News group under that account the Caption of
the "Get Mail" button may change to "Get messages". But that would probably need
a permanent change of the Buttons width to prevent an resize of it everytime you
select a different type of account in the sidebar.

Reproducible: Always

Steps to Reproduce:

Updated

15 years ago
QA Contact: asa

Comment 1

14 years ago
Better yet, have another icon there that becomes available. I agree that "Get
Mail" is not descriptive of what's going on. This problem occurs in Thunderbird
0.91, OS X 10.2.8. Someone please change the platform to "All".


Comment 2

11 years ago
"Get messages" is appropriate for all kinds of accounts. So it should be used.
QA Contact: front-end
CC'ing Bryan for this trivial UI issue.
We shouldn't have the button switching text depending on the type of account you're selecting.  There wouldn't be enough of an explanation why the text was changing so it could confuse people, plus it's not good to do this for accessibility.

If someone gets a chance we can switch the text to "Get Messages", which is more appropriate for any kind of account.  Though it makes a larger button we'll be making space on the toolbar with in the release anyway.

Comment 5

10 years ago
The behavior of the Get Mail button has changed on trunk so the drop down list now includes news accounts. The general label change to the universal "Get Messages" is most sensible.  Also, the combination of an icon and the drop arrow should provide enough cover for the longer text string. A simple tweak is to raise the drop arrow 1 or 2 px for improved separation.

Comment 6

10 years ago
I don't think that changed on trunk - normal news accounts have been in that list forever. Not the spurious "news" ones one can currently see though;)
Assignee: mscott → nobody

Comment 7

10 years ago
In Tb 2.0.0.12 only my one Mail account lists in the Get Mail drop down. None of my 4 news accounts is listed.  In the Tb3 trunk the News accounts do list. OS is Windows Vista, in case there may be an OS difference in behavior.

Comment 8

10 years ago
Just as a note: SeaMonkey has the toolbar button named "Get Msgs" with using "Messages" in menus, and "Get new messages" as the tooltip for the button.
Summary: "Get mail" should be "Get messages" for news accounts → "Get mail" should be "Get messages"
Duplicate of this bug: 449888

Comment 10

10 years ago
Some other options since the caption should be small would be "Update", "Sync", or "Get New".

Comment 11

10 years ago
(In reply to comment #10)
> Some other options since the caption should be small would be "Update", "Sync",
> or "Get New".
> 

The caption must be Screen reader compatible, the suggestions make no sense without a valid context, which is not provided by the icon a User can not see.
xref bug 391648 Widen the 'Get Mail' button

Evaluation of this bug

PRO
- The term "Mail" is more commonly associated with "Email", thus slightly inappropriate for getting News and Feed messages
- The term "Messages" is universally appropriate for all types of accounts

CON
- "Get Messages" as button label is significantly longer than "Get Mail", and though not ideal, it's still understandable in a News and Feed context what this button does. Add to that the current more informative tooltip which always says "Get new messages".
- I'd think most of our users use TB as a MAIL reader, with News and Feeds being less frequently used both generally and even by those users who have News and Feeds. (So for a majority of users, this will just make the button bigger without benefit, and even for affected users, the benefit is probably little).

Next steps for this bug:

* Provide Mockup Screenshots comparing, for each default theme, the size of "Get Mail" button before and after the proposed scheme, including measurement in pixels how many pixels are added.

* Discuss some more, provide alternatives if there are any...

* Decide if we want to do this or not (mostly for en-US, other languages have their own labels anyway, e.g. German has "Abrufen" which translates as "Receive") - if yes: do it! if not: wontfix.
Blocks: 391648
Summary: "Get mail" should be "Get messages" → "Get mail" button label should be "Get messages" (to be more appropriate for News and Feed accounts)
Whiteboard: [needs mockup screenshots]
(In reply to Susurrus from comment #10)
> Some other options since the caption should be small would be "Update",
> "Sync", or "Get New".

What about "Receive?"

That's a bit more universally appropriate (I think), yet short.
Slightly less crisp and charming though than the current "Get Mail".
Perhaps "Get Mail" is still a good compromise...

Comment 14

5 years ago
Fetch could also work. I think the previous suggeston of "Get new" is the best option so far.
(Assignee)

Comment 15

5 years ago
Created attachment 763733 [details] [diff] [review]
patch
Assignee: nobody → alta88
Attachment #763733 - Flags: ui-review?(bwinton)
Attachment #763733 - Flags: review?(bwinton)
Comment on attachment 763733 [details] [diff] [review]
patch

>+++ b/mail/locales/en-US/chrome/messenger/messenger.dtd
>@@ -486,17 +486,17 @@
>-<!ENTITY getMsgButton.label "Get Mail">
>+<!ENTITY getMsgButton1.label "Get Messages">

What about "getMessagesButton.label" instead?

(Having said that, that's a nit, so r=me, and ui-r=me.)

Thanks,
Blake.
Attachment #763733 - Flags: ui-review?(bwinton)
Attachment #763733 - Flags: ui-review+
Attachment #763733 - Flags: review?(bwinton)
Attachment #763733 - Flags: review+
(Assignee)

Comment 17

5 years ago
Comment on attachment 763733 [details] [diff] [review]
patch

[Approval Request Comment]

10yrs is long enough.  patch is a no risk string change.
Attachment #763733 - Flags: approval-mozilla-aurora?
(Assignee)

Updated

5 years ago
Keywords: checkin-needed
(Assignee)

Updated

5 years ago
Attachment #763733 - Flags: approval-mozilla-aurora? → approval-comm-aurora?
Comment on attachment 763733 [details] [diff] [review]
patch

Sorry, but string changes aren't generally allowed on branches, unless there's some really exceptional circumstances - as this would cause changes for l10n, some of whom will have already completed and signed off on their TB 24 strings. This will need to wait another year, but in the meantime our testing populations can enjoy it.
Attachment #763733 - Flags: approval-comm-aurora? → approval-comm-aurora-
https://hg.mozilla.org/comm-central/rev/322fc10273e5
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Keywords: checkin-needed
Resolution: --- → FIXED
Target Milestone: --- → Thunderbird 25.0

Updated

5 years ago
Keywords: polish
OS: Windows XP → All
Hardware: x86 → All
Whiteboard: [needs mockup screenshots]
Version: unspecified → Trunk
You need to log in before you can comment on or make changes to this bug.