crash when reading a mail message using mozilla-1.4 Xft build [@ XftDrawGlyphFontSpec ]

RESOLVED DUPLICATE of bug 213734

Status

Core Graveyard
GFX: Gtk
--
critical
RESOLVED DUPLICATE of bug 213734
14 years ago
9 years ago

People

(Reporter: James Henstridge, Assigned: blizzard)

Tracking

({crash})

1.4 Branch
x86
Linux
crash

Firefox Tracking Flags

(Not tracked)

Details

(crash signature)

Attachments

(2 attachments)

(Reporter)

Description

14 years ago
I have found a number of mail messages I have received cause Mozilla to crash. 

The system is pretty much a stock Red Hat 9 box (with errata packages applied),
running the GTK 2/Xft RPMs from ftp.mozilla.org.

I looked at a few other related bug reports, and couldn't see any that obviously
matched this one.  I do not have any windows .fon files in my fontconfig font path.

I saved one of the problem messages, and will attach it to this bug report.
(Reporter)

Comment 1

14 years ago
Created attachment 130718 [details]
sample message

Sample message.  When loading this message, mozilla segfaults immediately.
The strace only shows reads and writes on the X socket before the crash.

Comment 2

14 years ago
make sure all your TTF files are world-readable.
can you grab a stack trace with gdb?
bug 173204 would be the most likely culprit I can think of.
Blocks: 198955
(Reporter)

Comment 3

14 years ago
Created attachment 130727 [details]
backtrace

backtrace from gdb.  The mozilla build doesn't appear to have any debug info,
but I did have copies of Xft and GTK with debug info, so I used them to get a
bit more information in the trace.

(the trace looked similar using the versions of the libraries distributed with
RH9)
(Reporter)

Comment 4

14 years ago
The stack trace doesn't quite look like the one in bug 173204.

This one seems to occur in XftDrawGlyphFontSpec itself, rather than in the calls
to Xrender.  Maybe the length is being miscomputed or something?

Updated

14 years ago
Severity: normal → critical
Keywords: crash

Comment 5

14 years ago
please reopen if still crashing with latest nightly build:
http://ftp.mozilla.org/mozilla.org/pub/mozilla/nightly/latest

*** This bug has been marked as a duplicate of 213734 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → DUPLICATE
Summary: crash when reading a mail message using mozilla-1.4 Xft build → crash when reading a mail message using mozilla-1.4 Xft build [@ XftDrawGlyphFontSpec ]
Product: Core → Core Graveyard
Crash Signature: [@ XftDrawGlyphFontSpec ]
You need to log in before you can comment on or make changes to this bug.