Last Comment Bug 218037 - Extra white line between DIVs
: Extra white line between DIVs
Status: VERIFIED DUPLICATE of bug 173051
:
Product: Firefox
Classification: Client Software
Component: General (show other bugs)
: unspecified
: x86 Windows XP
: -- normal (vote)
: ---
Assigned To: Blake Ross
:
Mentors:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2003-09-01 22:20 PDT by Lawrence Kesteloot
Modified: 2006-02-12 04:46 PST (History)
0 users
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
HTML test case (1.08 KB, text/html)
2003-09-01 22:22 PDT, Lawrence Kesteloot
no flags Details
Screenshot of rendering problem (2.09 KB, image/png)
2003-09-01 22:25 PDT, Lawrence Kesteloot
no flags Details

Description Lawrence Kesteloot 2003-09-01 22:20:51 PDT
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.5a) Gecko/20030728 Mozilla Firebird/0.6.1
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.5a) Gecko/20030728 Mozilla Firebird/0.6.1

In the attached HTML file, there are three DIVs with colored backgrounds. 
Firebird shows a white horizontal line between the second and third DIV. 
Changing almost anything about the style sheet (size of text, etc.) makes this
white line go away.  It does not show up in Internet Explorer.  See attached
image for what it looks like.

Reproducible: Always

Steps to Reproduce:
Load attached HTML file.
Actual Results:  
See extra white line.

Expected Results:  
Not shown white line.  The three DIVs should all be stuck together.

<html>
    <head>
        <title>Mozilla Bug</title>
        <style type="text/css">
            body {
                background-color: white;
                font-size: 82%;
            }

            #upperMenuBar {
                height: 2.1em;
                background-color: #87dc64;
                color: white;
            }

            #header {
                color: #4e9027;
                background-color: #aae68c;
                font-size: 400%;
                padding-bottom: .1em;
            }

            #lowerMenuBar {
                height: 1.55em;
                background-color: #339900;
            }
        </style>
    </head>

    <body>
        <div id="upperMenuBar"></div>
        <div id="header">Mozilla Bug</div>
        <div id="lowerMenuBar"></div>

        <p>There should not be a one-pixel white line between the second
        and third green bar above.</p>

        <p>Seen with Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US;
        rv:1.5a) Gecko/20030728 Mozilla Firebird/0.6.1</p>
    </body>
</html>
Comment 1 Lawrence Kesteloot 2003-09-01 22:22:01 PDT
Created attachment 130761 [details]
HTML test case

Test case to reproduce bug.
Comment 2 Lawrence Kesteloot 2003-09-01 22:25:30 PDT
Created attachment 130762 [details]
Screenshot of rendering problem
Comment 3 Simon Paquet [:sipaq] 2003-09-02 03:35:37 PDT

*** This bug has been marked as a duplicate of 173051 ***

Note You need to log in before you can comment on or make changes to this bug.