preferences dialog is broken in Firefox

RESOLVED FIXED

Status

--
major
RESOLVED FIXED
15 years ago
14 years ago

People

(Reporter: sboulema, Assigned: bugzilla-mozilla-20000923)

Tracking

Trunk
x86
Windows XP
Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: cz-patch)

Attachments

(3 attachments)

(Reporter)

Description

15 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.5b) Gecko/20030828 Firebird/0.6.1+
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.5b) Gecko/20030828 Firebird/0.6.1+

when checking the preferences of chatzilla 0.9.35 on fb 20030828 the preferences
dialog only shows the first page of chatzilla options, but you can click on the
sub menus. the ok button doesnt work only the cancel button works.

Reproducible: Always

Steps to Reproduce:
1. open chatzilla
2. edit->preferences->chatzilla
3. dialog is broken

Actual Results:  
you cant change anything since ok button doesnt work and the other options then
the firts pagecant be reached

Expected Results:  
you can see all the options click on the su menu and change evrything press ok
and it works
(Assignee)

Comment 1

15 years ago
Firstly, Chatzilla is not in any way designed to work with Firebird. Secondly,
it (because of this) uses the Seamonkey (i.e. Mozilla, not Firebird) preferences
window. Chances are, Firebird's missing bits that are needed for it to work
correctly.

The prefs are going to be re-done at some point (soon?) to be independant of the
host browser, and should resolve this problem.

Comment 2

15 years ago
Whoa, not so fast.  Chatzilla *is* intended to work on firebird.  It's just that
the prefs need to be reworked so that they function properly in both mozilla AND fb.

Comment 3

15 years ago
Can't have it as an extension without the preferences.
Blocks: 214269

Updated

15 years ago
No longer blocks: 214269

Comment 4

15 years ago
*** Bug 226000 has been marked as a duplicate of this bug. ***
(Assignee)

Comment 5

15 years ago
Updating summary to indicate it's only in Firebird, and confirming.
Status: UNCONFIRMED → NEW
Ever confirmed: true
Summary: preferences dialog is broken → preferences dialog is broken in Firebird

Comment 6

15 years ago
Need prefs before we can add FB as a default bundle.
Blocks: 214269
(Assignee)

Updated

15 years ago
Blocks: 226305

Comment 7

15 years ago
Created attachment 137798 [details]
firebird-type options panel for chatzilla panels

mozilla/extensions/irc/xul/content/prefpanel/pref-irc-dlg.xul

Comment 8

15 years ago
Created attachment 137799 [details] [diff] [review]
patches jar.mn and contents.rdf.in to accommodate pref-irc-dlg.xul

Comment 9

15 years ago
Viewing attachment 137798 [details] I get 

XML Parsing Error: undefined entity
Location: http://bugzilla.mozilla.org/attachment.cgi?id=137798&action=view
Line Number 13, Column 1:<dialog id="ircPrefDialog" 

But that might be because I don't have CZ installed.
(Assignee)

Comment 10

15 years ago
Chris Neale, from what I can see, you're basically using the Firebird pref
window for that attachment, right? I'd be interested in knowing if it works, and
what it looks like.

I am, however, working on a complete replacement window for Chatzilla - so that
we have one that works in Mozilla *and* Firebird (with no dependencies on bits
of XUL or JS code already being there). Hopefully, it'll be done soon, and when
it is the 0.9.54c release should have it.
Assignee: rginda → silver
(Assignee)

Updated

15 years ago
Status: NEW → ASSIGNED

Comment 11

15 years ago
comment 9 - that's because I added attachment with the xul mime-type

comment 10 - looks pretty much like Firebird Options - works since it provides
all the hooks that seamonkey prefs did

uses buttons (instead of a tree) to switch panels
(Reporter)

Comment 12

15 years ago
tested the new version of chatazilla 0.9.45e and the new options dialog is 
working fine. only the last tab with the scrollbar needs to be changed in my 
opinion. marking this one fixed :)
Status: ASSIGNED → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → FIXED

Comment 13

15 years ago
it's not considered fixed until it's checked in.
Status: RESOLVED → REOPENED
Resolution: FIXED → ---
(Assignee)

Comment 14

15 years ago
Samir, what would you suggest for the 3rd tab?

We're working on a few behind-the-scenes improvements now, and probably grouping
the "munger" prefs (all those "Display <thing>" ones) properly. Suggestions for
better ways to lay things out welcome. :)
(Assignee)

Comment 15

15 years ago
Created attachment 140274 [details] [diff] [review]
The big one. This is everything for the Firebird-compatible preference window.

This is the preference window as seen in 0.9.58p, and similar special versions
of Chatzilla available from the hacksrus site.
(Assignee)

Updated

15 years ago
Attachment #140274 - Flags: review?(rginda)

Updated

15 years ago
No longer blocks: 214269
(Assignee)

Updated

15 years ago
Whiteboard: cz-patch

Updated

15 years ago
Summary: preferences dialog is broken in Firebird → preferences dialog is broken in Firefox

Comment 16

14 years ago
5 months later ... has this been checked in?  
Flags: blocking1.8a2?
Blocks: 212747
Blocks: 229564

Comment 17

14 years ago
Bug 212747 doesn't affect Firefox -> removing dependency.
And why should a problem with Firefox block the release of Mozilla 1.8a2?

Silver's checkin from 2004-06-08 20:33 (landing of 0.9.64) said that it fixes
this bug. Marking as fixed therefore.

cz 0.9.64b works fine in Firefox 0.9. But that wasn't checked in yet, see bug
245783. To work with the recent Firefox 0.9.0+ branch builds, the maxVersion in
cz's install.rdf needs to be bumped to 0.9.0+.
No longer blocks: 212747
Status: REOPENED → RESOLVED
Last Resolved: 15 years ago14 years ago
Flags: blocking1.8a2?
Resolution: --- → FIXED
Product: Core → Other Applications

Updated

13 years ago
Attachment #140274 - Flags: review?(rginda)
You need to log in before you can comment on or make changes to this bug.