Closed Bug 21812 Opened 20 years ago Closed 20 years ago

New windows don't always close

Categories

(SeaMonkey :: General, defect, P3, major)

x86
Windows NT

Tracking

(Not tracked)

VERIFIED WORKSFORME

People

(Reporter: marshall, Assigned: vparthas)

References

Details

With today's build 1999121408 (Dec 15th) new windows don't always close when you
hit the little x in the corner.  The web shells DO unload, as the window stops
drawing inter interface and content.  Soon after it causes the browser to crash.

This doesn't happen all the time, but it happens often enough to be annoying.

To get rid of the windows which won't close you have to close all the windows
and then the program exits gracefully.
Assignee: leger → varada
temp assign to varada for going thru the list
Status: NEW → RESOLVED
Closed: 20 years ago
Resolution: --- → WORKSFORME
Marking as WORKSFORME Windows build #1999121608
I could close multiple browser as well as mail and composer windows.
I got today's build and its still not working.  If I use the menu command it
works.  If I use the X it sometimes does, but most of the time it doesn't.  I
still can't pinpoint when it happens, but it crashes the browser when it does.
I just had it happen again 1999121612 (This computer is running WinNT server as
opposed to the previous one which was win98)
The windows are open but everything has been unloaded.  If I cause a full
repaint the browser will crash.

In the debug window I see
*** General Drag ***
*** General Drag ***
*** General Drag ***
*** General Drag ***
*** General Drag ***
*** General Drag ***
*** General Drag ***
*** General Drag ***
*** General Drag ***
Webshell- = 28
Webshell- = 27
Webshell- = 26
Webshell- = 25
Webshell- = 24
Webshell- = 23
Webshell- = 22
Webshell- = 21
Webshell- = 20
Webshell- = 19
Webshell- = 18
Webshell- = 17
Webshell- = 16
Webshell- = 15
Webshell- = 14
I just re-entered this very same bug as #22110 prior to reading this one.  It is
definitely a real problem, and a repeatable one.  It is also darn intermittent.
I would recommend that we mark mine as a dupe and re-open this one.  Until
further advised I'll leave the status of both these bugs as is.

BTW, running build 1999121712
*** Bug 22110 has been marked as a duplicate of this bug. ***
This seems to work for me on my build yesterday - will regress it for a few more
days and see if it reappears on any other machine or build.
Putting on verifyme keyword.
Keywords: verifyme
This has worked fine on all platforms for some time.  Definitely not a problem 
with 2000-03-22-06 builds.  marking Verified.
Status: RESOLVED → VERIFIED
Product: Browser → Seamonkey
Keywords: verifyme
You need to log in before you can comment on or make changes to this bug.