Web page does not recognize that cookies are enabled

RESOLVED INVALID

Status

()

Core
Networking: Cookies
--
major
RESOLVED INVALID
15 years ago
15 years ago

People

(Reporter: versionist, Assigned: Darin Fisher)

Tracking

Trunk
x86
Windows 98
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

15 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Win 9x 4.90; en-US; rv:1.5a) Gecko/20030718
Build Identifier: Mozilla/5.0 (Windows; U; Win 9x 4.90; en-US; rv:1.5a) Gecko/20030718

This web page does not recognize the fact that all cookies are enabled, and will
not let me proceed with login.  All cookies are enabled, and I even tried
"Unblock Cookies from This Site", even though they were not blocked in the first
place.  This also happend on
https://fleethomelink.fleet.com/cgi-bin/imcpprd.dll/Ctrl.jsp?page=topLevel&cntType=UCP_WELCOME

Try putting any information in the login box, and you will get a no cookie warning.

Reproducible: Always

Steps to Reproduce:
1. Go to https://onlineid.bankofamerica.com/cgi-bin/sso.login.controller?state=NJ


Actual Results:  
Redirected to a page with a message that cookies are not enabled.

Expected Results:  
Let the webpage know that cookies are enabled.

Comment 1

15 years ago
WFM with a current cvs build, Linux.

Please check the additional cookie related settings under
Preferences->Advanced->Scripts & Plugins. 

Make sure Javascript is enabled for the browser, and that it at least is allowed
to create, change and read cookies. (That's the last two checkboxes)
Then try again and report back.
works for me with build 2003-09-01-04, Windows 2000:

'The Online ID you entered is too short.

The ID must be 5-20 numbers. Please re-enter your Online ID.'

Comment 3

15 years ago
I have same kind of problem of my web site. http://fallenangels.combats.ru/admin/
i can't login .

Comment 4

15 years ago
It's not a bug. Just Mozilla can't handle JavaScript like this one
<script lamguage=javascript>window.location.replace("index.php"); </script>
After changing script to use Header to redirect, login page is works fine.


Comment 5

15 years ago
"Just Mozilla can't handle JavaScript like this one"
can you comment more on this ?
is this an evangelism bug ?
(Reporter)

Comment 6

15 years ago
"Please check the additional cookie related settings under
Preferences->Advanced->Scripts & Plugins. "

This did the trick.  Had the "Allow scripts to change and create cookies" 
disabled.

The only reason I needed IE is now eliminated!

Thanks.
-> invalid
Status: UNCONFIRMED → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → INVALID
You need to log in before you can comment on or make changes to this bug.