JavaScript Application pop up says : Old browsers cannot use menus without frames. Please upgrade.

RESOLVED INVALID

Status

Core Graveyard
Java: OJI
RESOLVED INVALID
15 years ago
8 years ago

People

(Reporter: Can Nakkasoglu, Assigned: Joshua Xia)

Tracking

Trunk
DEC
OpenVMS

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

15 years ago
User-Agent:       Mozilla/4.0 (compatible; MSIE 6.0; Windows NT 4.0; TESIEAK6a)
Build Identifier: Mozilla/5.0(X11;U;OpenVMS AlphaStation_255/300;en-US;rv:1.5b) Gecko/20030827

I connect to a PC http serving HP Openview SANworks HSG Element Manager (a SAN 
management and monitoring utility). I get a JavaScript Application pop up 
window with the "Old browsers...please upgrade" message as above. After I OK 
it, Mozilla hangs.

Mozilla version : 1.5b
Java SDK 1.4.1
OS: OpenVMS 7.3-1 with all patches

Reproducible: Always

Steps to Reproduce:
1.
2.
3.

Actual Results:  
Browser hangs

Expected Results:  
Should display graphical information showing SAN controllers and disks that HSG 
element Manager discovered.

Comment 1

15 years ago
Mozilla is not officially supported for this product, see the release notes:
http://h18000.www1.hp.com/products/sanworks/softwaredrivers/managementappliance/index.html

Did you hang with JRE 1.3.x ?
Assignee: rogerl → joshua.xia
Component: JavaScript Engine → OJI
OS: other → OpenVMS
Hardware: Other → DEC

Comment 2

15 years ago
Setting default QA -
QA Contact: pschwartau → general
(Reporter)

Comment 3

15 years ago
No. I followed installation steps for Mozilla 1.5b and it only requires Java 
SDK 1.3.1 + 



Support for the Java™ platform in Mozilla for OpenVMS 
Mozilla for OpenVMS requires the Software Development Kit (SDK) v 1.3.1-1 for 
the OpenVMS Operating System, for the Java™ Platform, to run Java applets. 
Version 1.3.1-1 and later releases of the SDK contain the required OJI (Open 
JVM Integration) support. 
All versions of Mozilla for OpenVMS, including M1.4, work with the SDK v 1.3.1-
1. Support for the SDK v 1.4-0 and higher is included only in Mozilla for 
OpenVMS M1.3 and higher. 
You can download the SDK from the Java for Alpha Systems software download page 
<http://h18010.www1.hp.com/java/download/index.html>.




Comment 4

15 years ago
In the "supported browsers" section of the SANworks release notes
ftp://ftp.compaq.com/pub/products/sanworks/techdoc/managementappliance/AA-RNEAJ-TE.pdf
it says that CSWB 1.0 and Java 1.3.1_04 are supported. It says nothing about
Mozilla or later version of Java. I see no reason why a later version of CSWB or
Mozilla shouldn't work, but I wouldn't assume that java 1.4.1 would work.

You are correct that Java 1.4.1 is supported with Mozilla 1.5b, but it doesn't
look like Java 1.4.1 is supported with the SANworks applet. I suggest you
contact HP support to find out if/when SANworks will support Java 1.4.1.

In the meantime I suggest you install Java 1.3.1_04 and try with that. Since you
can install multiple versions of Java installing 1.3.1_04 shouldn't interfere
with your Java 1.4.1 installatin.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → INVALID

Comment 5

15 years ago
By the way, did you used to run Java 1.3.1? If so, did the applet run then?

Updated

8 years ago
Component: Java: OJI → Java: OJI
Product: Core → Core Graveyard
You need to log in before you can comment on or make changes to this bug.