Closed Bug 218193 Opened 16 years ago Closed 16 years ago

Ability to permanently hilight some text on web page

Categories

(SeaMonkey :: General, enhancement)

enhancement
Not set

Tracking

(Not tracked)

RESOLVED DUPLICATE of bug 12305

People

(Reporter: malx, Unassigned)

Details

(Keywords: helpwanted)

User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.5a) Gecko/20030718
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.5a) Gecko/20030718

Request for feature:
 User should be able to hilight some text on page. It could be hilighted text
background, anchor or arrow-image pointing to something. Also it whould be great
to add some simple notes (like title= do) to some items.
 And there should be simple way of transfering your hilight to other person. It
could be "Mail page with hilight/comments" or some special URL
(http://serv/page.hmtl#-moz-hilight-123,4234,5435... ?)

 Reason - On long pages it is essential to mark part of interest to you or
someone else. Editors could mark text in own site page to be corrected and send
this hilight-link to webmaster. etc.

 Possible solution.
Really do not know :(
Something with DOM. Some way of including <a name=SPECIAL class=hilight> .. </a>
to the node of interest (so page whould scroll to this place) and some absolutly
positioned arrow-image, which will get X,Y from that SPECIAL anchor (to be
correct with any font size and window size).

 It May be external RDF file ( "Export page/site hilights..." ) with all
hilights description.

Reproducible: Always

Steps to Reproduce:
For page annotations, it's a dupe of bug 12305. I've seen a request for a
hilighter too, but I can't find it back.

PS : check out http://annozilla.mozdev.org/

*** This bug has been marked as a duplicate of 12305 ***
Status: UNCONFIRMED → RESOLVED
Closed: 16 years ago
Resolution: --- → DUPLICATE
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.