When opening new tab, location bar does not get focus immediately (text is selected after delay)

RESOLVED INCOMPLETE

Status

()

Firefox
General
RESOLVED INCOMPLETE
15 years ago
5 years ago

People

(Reporter: Jeremy M. Dolan, Unassigned)

Tracking

Trunk
x86
All
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

15 years ago
1) Hit Ctrl+T
2) Start typing a URL
3a) If you continue to type, you will notice you lost the first 4 or 5
characters you entered. I always assumed the tab simply hadn't recieved the
input that early.
3b) If you stop typing, you will notice all of the text in the URL bar is
selected, (as during a URL bar click/Ctrl-L/Alt-D).

This selection has no purpose (new tabs don't have any text in the URL bar, as
they load a blank page) and causes initialy typed characters to be overwritten.
(Reporter)

Comment 1

15 years ago
What are the relevant preferences here?

I have browser.urlbar.clickSelectsAll set to false, clicking still selects all,
and this problem remains. It's driving me batty. Is clickSelectsAll broken on GTK2?
Component: Autocomplete → General

Comment 2

14 years ago
Maybe bryner can help.
Assignee: hewitt → bryner
I've been affected by this bug too.

If I am understanding this correctly, the url bar is getting focus after the tab
has loaded, and when the url bar normally gets focus, it selects all the text
that is there. The problem is that if you are quick enough, it is possible to
write text before the bar gets focus, so when it does, the text is overwritten.
Another effect would be bug 254656, where it is possible to paste into a textbox
in the previous tab if you're quick enough.

Jeremy: I don't know about any browser.urlbar.clickSelectsAll breakage, but
you're right that that is a possible workaround.
OS: Linux → All
Summary: When opening new tab, text is selecting in URL bar after delay → When opening new tab, location bar does not get focus immediately (text is selected after delay)
*** Bug 254656 has been marked as a duplicate of this bug. ***
(Reporter)

Comment 5

14 years ago
yes, that re-summing is correct. I don't see this as often anymore, but I still
can reproduce it if I really try. I suspect new-tab performance improvements
have cut the window with which you can trigger this down.

And FWIW, the browser.urlbar.clickSelectsAll still seems not to be honored. With
it set to either true or false in Linux, clicking the URL bar does not select
the text.

Comment 6

14 years ago

*** This bug has been marked as a duplicate of 200664 ***
Status: NEW → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → DUPLICATE
(Reporter)

Comment 7

14 years ago
Reopening. Bug 200664 is a different issue, in a different product.
Status: RESOLVED → REOPENED
Resolution: DUPLICATE → ---

Comment 8

13 years ago
On Mac Os X Panther with FireFox 1.04 very often the entire Adressbar and all
Textfields are entirely disabled after having a Window with a few tabs open for
a while.
I see no correlation to plugins which I first assumed, but the only solution
then is to close the entire Window and start a new one. It's like the Window is
frozen for textentries.
I download 1.06 now and observe this problem.

Updated

13 years ago
Depends on: 249136

Comment 9

13 years ago
Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9a1) Gecko/20050812 Firefox/1.0+
ID:2005081219

Works for me. Please feel free to reopen if you can reproduce with the latest
builds.
Status: REOPENED → RESOLVED
Last Resolved: 14 years ago13 years ago
Resolution: --- → WORKSFORME

Comment 10

12 years ago
Reopening this bug, I can reproduce it using a 20060206 Windows Firefox nightly. You have to be pretty fast, but I do a lot of web searches so this bites me several times a day. Here is what I see:

1. Press Ctrl-T to open a new tab.
2. Immediately (within less than 1 second) press Ctrl-K to focus the search box.
3. Start typing your query.

Expected result: The text is entered in the search box.
Actual result: The text is entered in the URL bar.

If you wait a second after opening the new tab before doing step 2, this does not occur.
Status: RESOLVED → REOPENED
Resolution: WORKSFORME → ---
QA Contact: davidpjames → location.bar
Assignee: bryner → nobody
Status: REOPENED → NEW
QA Contact: location.bar → general
Version: unspecified → Trunk

Comment 11

10 years ago
Jon, anyone, Did problem go away? Or do you still see this?

WFM Mozilla/5.0 (Windows; U; Windows NT 6.0; en-US; rv:1.9.1a1pre) Gecko/2008061303 Minefield/3.1a1pre
Whiteboard: CLOSEME 2008-08-01

Comment 12

10 years ago
Jon or anyone else: feel free to re-open
Status: NEW → RESOLVED
Last Resolved: 13 years ago10 years ago
Resolution: --- → INCOMPLETE
Whiteboard: CLOSEME 2008-08-01

Comment 13

10 years ago
Looks like it WFM for me, too.

Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9.0.3) Gecko/2008092510 Ubuntu/8.04 (hardy) Firefox/3.0.3

Comment 14

5 years ago
This still happens in private browsing windows for me when opening a new tab. The location bar is selected initially, and the first few characters will get re-selected after a short delay.

It only happens in private browsing, and only on a very slow laptop. Firefox 20.0.
You need to log in before you can comment on or make changes to this bug.