Message Filter Rules Dialog: Unable to change items after specifying a customized header

VERIFIED DUPLICATE of bug 212625

Status

Thunderbird
Mail Window Front End
--
minor
VERIFIED DUPLICATE of bug 212625
15 years ago
12 years ago

People

(Reporter: Liam Edgeley, Assigned: Scott MacGregor)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

15 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.5a) Gecko/20030728 Mozilla Firebird/0.6.1
Build Identifier: Mozilla Thunderbird 0.2 (20030901)

When creating a new message filter rule (or making changes to an existing one),
if you add a customized header, the following happens:

The header to match reverts to 'Subject'
You can no longer change which header to match
You can no longer change the name of the filter rule
You can no longer change the text to be matched by the filter rule

Reproducible: Always

Steps to Reproduce:
1. Create a new (or alter an existing) message filter rule
2. In the panel beow 'Match all of the following', change the header from
'Subject' to 'Customize...'
3. Pick an item for the list, or create a new one
4. Select OK
Actual Results:  
The header to match reverted to 'Subject'
You cannot change which header to match
You cannot change the name of the filter rule
You cannot change the text to be matched by the filter rule

Expected Results:  
The header to match changes to reflect your customized header
The rest of the dialog should remain alterable

This is relatively easy to workaround - after you've added your customized
header to the list, it becomes an item on the 'header to match' drop-down. If
you cancel the changes made to the message rule and then attempt to edit it
again, you can select your customized header from the drop-down list, which does
not stop you from making any changes in the dialog.

Comment 1

15 years ago

*** This bug has been marked as a duplicate of 212625 ***
Status: NEW → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → DUPLICATE

Comment 2

15 years ago
making it easier for people to look for duplicates..
Summary: Message Filter Dialog: Unable to change items after specifying a cutomized header → Message Filter Rules Dialog: Unable to change items after specifying a customized header

Comment 3

15 years ago
verified dupe.
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.