Unable to close Address picker window by clicking OK if the addressee doesn't have an email address

VERIFIED FIXED in M18

Status

SeaMonkey
MailNews: Address Book & Contacts
P3
normal
VERIFIED FIXED
19 years ago
14 years ago

People

(Reporter: marina, Assigned: varada)

Tracking

Trunk
x86
Windows NT

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [nsbeta3+]-have fix in hand)

(Reporter)

Description

19 years ago
This might be as designed but maybe some warning has to pop up in that case
(like : you forgot to eneter an email address).
Steps to reproduce:
- enter a new card into the Address Book where email address is missing;
-bring up a Composition window;
-click Address icon and select in the Address picker a card with no email
address;
-now try to OK the dlgbox;
//note: nothing happens, you can dismiss it only by canceling

Updated

19 years ago
QA Contact: lchiang → esther

Updated

19 years ago
Status: NEW → ASSIGNED
Target Milestone: M13

Updated

19 years ago
Target Milestone: M13 → M15

Comment 1

19 years ago
Bumping to M15

Comment 2

18 years ago
Mass moving to M17
Target Milestone: M15 → M17

Comment 3

18 years ago
Mass move mailnews bugs to Putterman.  Ouch.
Assignee: hangas → putterman
Status: ASSIGNED → NEW

Comment 4

18 years ago
Update: still exists on builds 5-10-00 all platforms.

Comment 5

18 years ago
moving to future milestone.
Target Milestone: M17 → Future

Comment 6

18 years ago
Im changing my mind and asking for reevaluation.  Perhaps we should disable the 
buttons that allow you to add an address if there's a card selected with no 
email address?
Target Milestone: Future → M18

Comment 7

18 years ago
This is for disabling the Add button.  If it turns out to be easier to put up a 
dialog then let's do that instead.
Keywords: correctness, nsbeta3

Updated

18 years ago
Keywords: mail2

Comment 8

18 years ago
reassigning to varada
Assignee: putterman → varada

Comment 9

18 years ago
+ per mail triage
Whiteboard: [nsbeta3+]
(Assignee)

Updated

18 years ago
Status: NEW → ASSIGNED
(Assignee)

Updated

18 years ago
Whiteboard: [nsbeta3+] → [nsbeta3+]-have fix in hand
(Assignee)

Comment 10

18 years ago
Marking Fixed.
If a card doesnt have a primary email - we throw a dialog that asks them to
remove it.
Status: ASSIGNED → RESOLVED
Last Resolved: 18 years ago
Resolution: --- → FIXED

Comment 11

18 years ago
Using build 2000-08-25 win98, mac and linux this is fixed (we get an error
message asking to remove the card from the list). Verified.
Status: RESOLVED → VERIFIED
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.