Pasting bulleted lines into a Composer document excludes <ul> tags, and editing the pasted text causes Mozilla to crash

RESOLVED WORKSFORME

Status

SeaMonkey
Composer
--
critical
RESOLVED WORKSFORME
15 years ago
14 years ago

People

(Reporter: Scott Chapin, Unassigned)

Tracking

({crash})

Trunk
x86
Linux
crash

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

15 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.4) Gecko/20030703
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.4) Gecko/20030703

This one's a little tricky to describe...

Say that you're copying/pasting the following lines from any HTML page to a new
Composer document:

o Bullet 1
o Bullet 2   <--- copy/paste this line
o Bullet 3   <--- copy/paste this line
o Bullet 4

(Note that I didn't copy/paste all the bulleted lines, or any un-bulleted lines
before / after them)

When those two lines are pasted in the new page, you can view the source and see
that the <li> </li> tags moved over, but not the <ul> </ul> tags.  

This is not a huge deal itself, but if you then do something like highlight
those lines in Composer, change the outdent, and then click on the text to edit
it, Mozilla will crash.

Reproducible: Always

Steps to Reproduce:
1. Highlight a range of bulleted lines from an existing HTML page (do not
copy/paste the entire list of bulleted lines, or include an un-bulleted line
before/after the bulleted lines)

2. Paste the lines into a new Composer document - if you check the page source,
you'll notice that the <ul> </ul> tags are not present.

3. Highlight the pasted bulleted lines and click the "outdent text" button

4. Click on the text to edit it - Mozilla will crash.
Actual Results:  
Mozilla go boom

Expected Results:  
Mozilla should either:

a.  Include the <ul> </ul> tags when copying/pasting a range of bulleted lines

b.  Not crash when the <ul> </ul> tags are not there

Comment 1

15 years ago
Could you retry it in latest nightbuild or 1.5b build?
Severity: normal → critical
Keywords: crash

Comment 2

15 years ago
worksforme with linux trunk 2003090405

Comment 3

15 years ago
Works For Me on current CVS build
Status: UNCONFIRMED → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → WORKSFORME
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.