e-pass.com - Embedded Java causes 100% CPU useage (system becomes nearly unuseable)

RESOLVED FIXED

Status

Tech Evangelism Graveyard
English US
--
critical
RESOLVED FIXED
15 years ago
3 years ago

People

(Reporter: Kevin Ar18, Unassigned)

Tracking

Details

(URL)

(Reporter)

Description

15 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.5b) Gecko/20030903 Firebird/0.6.1+
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.5b) Gecko/20030903 Firebird/0.6.1+

The site e-pass.com causes severe system degradation.

Reproducible: Always

Steps to Reproduce:
1. Visit: http://www.e-pass.com/
2. Then right click on the "more" link and select "Open in New Window."
Actual Results:  
At that point, the system becomes slow and unresponsive until something is done
to close Mozilla Firebird.  Although I cannot actually confirm this, I believe
that the CPU useage is pegging out at maximum.  (The reason I say this, is
because my Power Supply fan kicks in to a faster speed, which normally happens
during constant 100% CPU useage.)

The only way to recover the system is to close Mozilla Firebird.  Sometimes the
small "X" button can be clicked and the end task window will appear.  At other
times I have attempted to open task manager to end the process.  Trying to
launch task manager can take some time due to the slow system response.

Expected Results:  
Page should display without severe system degradation.
(Reporter)

Comment 1

15 years ago
BTW, I am using the
Java(TM) 2 Runtime Environment, Standard Edition 1.4.2
Default Virtual Machine Version 1.4.2-b28
Java(TM) Plug-in 1.4.2

Updated

15 years ago
QA Contact: asa

Comment 2

15 years ago
Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.6a) Gecko/20031002
Firebird/0.7+
Java Plug-in 1.4.2 for Netscape Navigator 

I was able to reproduce the slow and unresponsive behavior.  After about 5
minutes the new window loaded.  The java menu is the culprit.  The Microsoft
java eventually is interpreted by Sun's java though this is slow.

fphover.class Author: Tom Blumer Created with Microsoft Visual J++ Version 1.1

Possibly reassign to tech-evangelism.

Updated

15 years ago
Status: UNCONFIRMED → NEW
Ever confirmed: true

Updated

15 years ago
Assignee: blake → english-us
Component: General → English US
Product: Firebird → Tech Evangelism
QA Contact: english-us

Comment 3

14 years ago
Using Firefox 0.8 final SSE2 on Athlon64 and Win XP patched, JRE 1.4.2_03 it
works almost without hassle at all, but in fact I agree this page has really bad
java code....

Comment 4

14 years ago
Conforming summary to TFM item 10 at 
http://www.mozilla.org/projects/tech-evangelism/site/procedures.html#file-new
Summary: Embedded Java causes 100% CPU useage (system becomes nearly unuseable) → e-pass.com - Embedded Java causes 100% CPU useage (system becomes nearly unuseable)
(Reporter)

Comment 5

14 years ago
Question: Is this really the site's problem and not something that needs to be
fixed in Firefox or Java?

If it was, for example, an infinite loop, or whatnot, then I would agree that it
would be bad coding.  However, it doesn't appear to be coding issues (since the
performance problem is not present in IE w/ Microsoft's Java).  Thus, I would
assume that this should be filed under a bug for Firefox or as something that
Sun needs to fix in their Java implementation.

Please reply back.  I just don't want us to overlook what may be a problem in
Firefox or Sun's java by simply having the site redo something to work around it.
the seems to be working with JRE1.6 U11
Status: NEW → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → FIXED
Product: Tech Evangelism → Tech Evangelism Graveyard
You need to log in before you can comment on or make changes to this bug.