After installation only the user 1000 had the right to do anything (rwx------)

RESOLVED WORKSFORME

Status

Thunderbird
Build Config
--
minor
RESOLVED WORKSFORME
15 years ago
13 years ago

People

(Reporter: Markus Kuehnemann, Assigned: Scott MacGregor)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

15 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.5a) Gecko/20030728 Mozilla Firebird/0.6.1
Build Identifier: http://ftp.mozilla.org/pub/thunderbird/releases/0.2/thunderbird-0.2-i686-pc-linux-gtk2-gnu.tar.bz2

After unpacking the archive into the installation directory I've chosen all
files were set to rwx------ permission. Since I didn't name any of my users
"1000" none of them was able to do anything with the thunderbird. OK, no big
problem, I just adjusted the rights correctly, so everything is allright now,
but it would be nice to have it adjusted from the beginning as it used to be in
version 0.1. All has been done as root.

Reproducible: Always

Steps to Reproduce:
1.Download Mozilla Thunderbird 0.2
2.Unpack the archive, let's say into /usr/local
3.Start it as any user

Actual Results:  
Nothing - KDE of course could not find the executable and complained about that
in a dialog.

Expected Results:  
Thunderbird should have started.

As compnent I have chosen "Build Config", because it was closest to the theme
"binary installation". I know that everything is already built and configured,
sorry if this led to any confusion. It is easy to work around the bug by setting
the correct permission settings. I have noticed that there is a similar problem
with Mozilla browser packages (Bug 189905) and there is a guess that the package
might have been packed under WindowsXP and therefore the permissions are a bit
puzzled when unpacked under Linux, but I don't know whether this is the clue to
this thunderbird issue.

Comment 1

13 years ago
Markus - has this been fixed since you filed this 15 months ago?

Comment 2

13 years ago
Over 1 month with no response from reporter -> WFM. Please reopen if bug still
present in a recent build.

Updated

13 years ago
Status: NEW → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.