Closed Bug 21839 Opened 20 years ago Closed 20 years ago

[DOGFOOD]Can only subscribe to one newsgroup at a time.

Categories

(MailNews Core :: Backend, defect, P3)

x86
Other
defect

Tracking

(Not tracked)

VERIFIED FIXED

People

(Reporter: scottputterman, Assigned: sspitzer)

Details

(Whiteboard: [PDT+])

With a build from the morning of 12/15 I can only subscribe to one newsgroup at
a time.

Actually I can subscribe to as many as I want, but only the last one shows up
the next time I start up.

Here are the steps I followed:

I created a new account for news.mozilla.org

I used the subscribe dialog to subscribe to n.p.m.mail-news, n.p.m.xpfe, and
n.p.m.xpcom.  Then I quit.

When I started up, only n.p.m.xpcom showed up in the list and a newsgroup that
doesn't really exist called "s" showed up under it.

I've reproduced this 3 times in a row.  The news.mozilla.org file also only
lists n.p.m.xpocm and "s".
I tried adding another newsgroup, n.p.m.performance and then when I quit, that
was the only newsgroup that showed up. n.p.m.xpcom no longer showed up.
QA Contact: lchiang → huang
Whiteboard: [PDT+]
Putting on PDT+ radar.
Status: NEW → ASSIGNED
Target Milestone: M13
marking m13.  working on this now.
note, this is windows only.  looking at the code now.
Target Milestone: M13 → M12
marking m12, going to check in the fix now.

thanks for finding this, putterman.
Status: ASSIGNED → RESOLVED
Closed: 20 years ago
Resolution: --- → FIXED
Thanks for fixing this so fast.  It works for me now.
OK using 12-16-12m12 commercial builds linux 6.0 and NT 4.0.
Tried with migrated news servers and also new (news) account.
Status: RESOLVED → VERIFIED
OK using 12-16-12m12 commercial build mac OS 8.5.1
Yes. Work OK for all the platforms for 12-16-12-M12 commercial build.
Product: MailNews → Core
Product: Core → MailNews Core
You need to log in before you can comment on or make changes to this bug.