DIsplay of indic script in unicode is incorrect. It does not put the glyphs together.

RESOLVED WORKSFORME

Status

()

Core
Layout: Text
RESOLVED WORKSFORME
15 years ago
7 years ago

People

(Reporter: Ramarao Kanneganti, Assigned: Prabhat Hegde)

Tracking

({intl})

Trunk
x86
Linux
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(1 attachment)

(Reporter)

Description

15 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.5a) Gecko/20030728 Mozilla Firebird/0.6.1
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.5a) Gecko/20030728 Mozilla Firebird/0.6.1

The page written in Unicode Telugu, displays correctly in IE on XP. In Mozilla,
the characters are displayed, but the glyphs are not properly formed. I am not
sure of the technical details, but I may be able help out.

Reproducible: Always

Steps to Reproduce:
1. Open the webpage
2.
3.

Actual Results:  
Displays the unicode indic script incorrectly.

Expected Results:  
It should display it correctly. For example, k+a forms a new glyph and it should
produce that instead of using two characters k and a.

The script given in the webpage in Telugu.

There are lot of Telugu people that are looking to use Firebird. There is a
strong push in the govt to use Linux and if Firebird can display Telugu on
Linux, it would mean a lot of happy users. Thanks.
(Reporter)

Comment 1

15 years ago
Sorry. I think it should be filed into a different category. It is a browser
bug. Not a firebird bug per se.
Component: General → Complex Text Layout
Product: Firebird → Browser
Version: unspecified → 1.4 Branch

Comment 2

15 years ago
Updating owner/qa
Assignee: blake → prabhat.hegde
QA Contact: asa → art

Comment 3

15 years ago
So, is this a bug on Linux? Note that on Win 2k/XP, Mozilla has more or less the
same capability as MS IE in terms of _rendering_ complex script(various Indic
scripts, Thai, Korean) support. When it comes to editing/selection/cursor
movement, MS IE is ahead of Mozilla. Anyway, assuming that this is about Linux,
I'm changing the OS to Linux. I'm also changing the version to 'trunk' because
we won't fix it in 1.4branch. 

See the international release note (for Mozilla 1.5 : help | release notes and
follow the link to 'known issues : international issues'), bug 214719, bug
215119, bug 204439, and bug 204286. Applying attachment 130373 [details] [diff] [review] (to bug 215119)
to the trunk would enable Mozilla to render Indic scripts correctly. As for
Telugu, with the patch applied, it depends on whether Pango supports it or not
(http://www.pango.org)
Keywords: intl
OS: Windows XP → Linux
Version: 1.4 Branch → Trunk

Comment 4

14 years ago
Created attachment 146818 [details]
Screeshot of difference in rendering between IE and FireFox

I am using FireFox 0.8 milestone release in windows XP.
Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.6) Gecko/20040206
Firefox/0.8

And, I do see this problem not only with Telugu but also hindi. A great test
site is localised google site. www.google.co.in. I hereby attach a image which
shows the difference in rendering between IE and FireFox. While, the top
section shows IE rendering which is accurate, bottom section shows rendering as
done by Firefox
This is an automated message, with ID "auto-resolve01".

This bug has had no comments for a long time. Statistically, we have found that
bug reports that have not been confirmed by a second user after three months are
highly unlikely to be the source of a fix to the code.

While your input is very important to us, our resources are limited and so we
are asking for your help in focussing our efforts. If you can still reproduce
this problem in the latest version of the product (see below for how to obtain a
copy) or, for feature requests, if it's not present in the latest version and
you still believe we should implement it, please visit the URL of this bug
(given at the top of this mail) and add a comment to that effect, giving more
reproduction information if you have it.

If it is not a problem any longer, you need take no action. If this bug is not
changed in any way in the next two weeks, it will be automatically resolved.
Thank you for your help in this matter.

The latest beta releases can be obtained from:
Firefox:     http://www.mozilla.org/projects/firefox/
Thunderbird: http://www.mozilla.org/products/thunderbird/releases/1.5beta1.html
Seamonkey:   http://www.mozilla.org/projects/seamonkey/
Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9pre) Gecko/2008053101 SeaMonkey/2.0a1pre

The testcase page seems to have been changed. What I see "seems" to me to look more like the "correct" than the "incorrect" case, BUT, as I don't know Telugu, I can't tell if what I see is really what it ought to be.

Updated

10 years ago
Component: Layout: CTL → Layout: Text
QA Contact: arthit → layout.fonts-and-text
A sample text (text/plain) plus a snapshot (image/gif or similar) of how it "ought" to look like, both as attachments to the bug, would be a nice idea. See also bug 212505 for a similar example (but with testcase) in devanagari.

Comment 8

7 years ago
Problem not seen in later versions dating back to Firefox 3.0
Status: UNCONFIRMED → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.