If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

scrolling function of mouse isn't working

RESOLVED WORKSFORME

Status

SeaMonkey
General
--
minor
RESOLVED WORKSFORME
14 years ago
13 years ago

People

(Reporter: Lutz Pescht, Assigned: mkaply)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

14 years ago
User-Agent:       Mozilla/5.0 (OS/2; U; Warp 4.5; en-US; rv:1.3) Gecko/20030313
Build Identifier: Mozilla/5.0 (OS/2; U; Warp 4.5; en-US; rv:1.3) Gecko/20030313

When trying to scroll up/down, left/right with the mouse stick of a IBM ThinkPad T20
mozilla does not show the correct pointer. It should be a symbol of four arrows, but
mozilla shows only the arrows for up/down directions. That would be correct for
a wheel mouse but not for a stick. But even in these directions it does not
start scrolling the page as other applications on same system do.
When attaching a Logitech Trackman Marble Wheel even the mouse pointer does'nt
change. And still no scrolling in either direction.

Reproducible: Always

Steps to Reproduce:
1. Have a wheel or stick mouse. (e.g. Logitech Trackman Marble Wheel, IBM
ThinkPad T20)
2. In mozilla open a window with a page larger than the window.
3. Try to scroll with the wheel or stick of your mouse.

Actual Results:  
As it is a lack of function nothing happened.

Expected Results:  
Scroll the page within the window in up/down direction with a wheel mouse and in all
four directions with the stick mouse of the T20.

Reproduced on two systems with different hardware and operating systems OS/2
4.51 and 4.52
OS: other → OS/2
could be a dupe of bug "20618" but unsure about OS/2
(Assignee)

Comment 2

14 years ago
There is a new OS/2 mouse driver that will be coming out very soon that will fix
this.
Over to mkaply to resolve or not appropritely if/when said driver is out.
Assignee: general → mkaply
(Assignee)

Comment 4

14 years ago
Can you please get the new OS/2 single mouse device driver at:

http://service.software.ibm.com/os2dd/free/SingleMouse/SMouseEN.exe

And see if it fixes your problems?
(Assignee)

Comment 5

14 years ago
I got a note from the reporter and with the new mouse driver, this is working great.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → WORKSFORME
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.