Using scrollwheel calls onmouseout() event when it shouldn't

RESOLVED WORKSFORME

Status

()

Core
DOM: Events
--
minor
RESOLVED WORKSFORME
15 years ago
11 years ago

People

(Reporter: Brent Goldman, Unassigned)

Tracking

({testcase})

Trunk
x86
All
testcase
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

15 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.5a) Gecko/20030728 Mozilla Firebird/0.6.1
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.5a) Gecko/20030728 Mozilla Firebird/0.6.1

A table row in an HTML page (in phpMyAdmin to be specific) has the ONMOUSEOVER
property defined to call a JavaScript function which highlights (changes the
background color of) the row, and the ONMOUSEOUT property defined to call a
different function which changes the background color back.

When the mouse is over that table row (and the row gets highlighted), and I use
the scrollwheel on the mouse (which doesn't actually move the mouse on the
screen OR relative to the page, since the page is less than one screen long),
the table row unhighlights.

I can't see any other explanation for this other than that the row's ONMOUSEOUT
event is being triggered.

Reproducible: Always

Steps to Reproduce:
1. Load up the _Browse_ page for any table in phpMyAdmin which has at least one
row (but not so many rows that the frame's length is longer than one screen height)
2. Move your mouse over one of the rows, and watch the row's background color change
3. Rotate the scrollwheel on your mouse, watch the mouse stay at the same place
on the screen and relative to the page, and notice that the background color
changes for the cell (even though the ONMOUSEOUT event should not have been
triggered)

Actual Results:  
The ONMOUSEOUT event was triggered when it shouldn't've been

Expected Results:  
Mozilla should not have triggered the ONMOUSEOUT event
Can you attach a testcase or a URL to this bug?

Comment 2

15 years ago
Created attachment 131026 [details]
Testcase that triggers onmouseout when mousewheel is used

Updated

15 years ago
Keywords: testcase
OS: Linux → All
(Reporter)

Updated

15 years ago
Summary: using scrollwheel seems to call onmousedown() event even when it shouldn't → using scrollwheel seems to call onmouseout() event even when it shouldn't

Updated

15 years ago
Status: UNCONFIRMED → NEW
Ever confirmed: true
Summary: using scrollwheel seems to call onmouseout() event even when it shouldn't → Using scrollwheel calls onmouseout() event when it shouldn't
No onmouseout triggered by mousewheel on testcase with Mozilla/5.0 (X11; U; Linux x86_64; en-US; rv:1.8.1.4) Gecko/20070621 Firefox/2.0.0.4,
or Mozilla/5.0 (X11; U; Linux x86_64; en-US; rv:1.9a6pre) Gecko/20070629 Minefield/3.0a6pre.  Thanks for reporting.  Please reopen if you still see the problem.
Status: NEW → RESOLVED
Last Resolved: 11 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.