[PP]linux and Mac only- default caret postion inconsistencys in Compose window

VERIFIED FIXED in M14

Status

P3
major
VERIFIED FIXED
19 years ago
11 years ago

People

(Reporter: esther, Assigned: saari)

Tracking

({platform-parity})

Trunk
HP
Linux
platform-parity

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

19 years ago
Using build 1999121508m12 on linux only, when you open a New Msg window, the
cursor is in the message body by default and but there is no focus (if you start
typing it goes nowhere), curor should be in the Addressing To: field

Using build 1999121508m12 on mac only, the cursor isn't displaying but the focus
is in the Addressing To: field as it should be (if you start typing the email
address it's in the right place).

Using build 1999121509m12 on Window is OK.

I looked for opened bugs on the default postion of cursor for a New Msg window
and I could not find one, so here it is.
Assignee: ducarroz → beppe
Summary: [PP]linux and Mac only- default cursor postion inconsistencys in Compose window → [PP]linux and Mac only- default cursor postion inconsistencys in Compose window
reassign to editor folk. MsgCompose set the focus into the first <to> field but
for some reason, doesn't works very well on all platform. It may be an
activation or a focus problem.

Updated

19 years ago
Target Milestone: M13

Comment 2

19 years ago
assigning to jfrancis, setting to m13

Updated

19 years ago
Assignee: beppe → jfrancis

Comment 3

19 years ago
actually assigning to jfrancis this time

Comment 4

19 years ago
I'm worried that this may not be an editor bug, but I wont be able to investigate
til Jan.
Status: NEW → ASSIGNED

Updated

19 years ago
Assignee: jfrancis → buster
Status: ASSIGNED → NEW

Comment 5

19 years ago
assigning this one to buster for review/debugging

Updated

19 years ago
Assignee: buster → saari

Comment 6

19 years ago
This is a hyatt/saari focus bug.  Assigning to saari, cc hyatt.  Nothing has
changed about the way the editor displays the caret of focus, so we must not be
getting the focus message.

I know saari checked in some focus fixes since this bug was submitted.  Could QA
please verify that it's still a problem on Mac and Linux?  Thanks!

Comment 7

19 years ago
esther - can you double check?
(Reporter)

Comment 8

19 years ago
Using 20000104 builds on mac linux and win98 here is what's happening now when
you click New Msg:
Mac - cursor is not visible, just start typing and the text is displayed in the
To: addressing field as you type.   Should have visible cursor.

Linux - cursor is visible and flashing in body of message, just start typing,
the cursor doesn't move and no text is visible.  Should have visible cursor in
first Addressing field, should have focus so when you start typing the text is
displayed as typed.

Win98 - is OK, cursor is in To: addressing field, just start typing and the text
is displayed as typed.

Updated

19 years ago
Summary: [PP]linux and Mac only- default cursor postion inconsistencys in Compose window → [PP]linux and Mac only- default caret postion inconsistencys in Compose window

Comment 9

19 years ago
Changing summary from "cursor" to "caret"
(Assignee)

Updated

19 years ago
Assignee: saari → beppe
(Assignee)

Comment 10

19 years ago
I don't think this particular bug is focus related. If the characters are getting
to the right place, I think focus is fine, *especially* if the cursor shows up
after you start typing. We're not mucking with focus at that point. The non-xp
nature of this also doesn't point to focus problems.

Could someone else please look at this?

Updated

19 years ago
Assignee: beppe → jfrancis

Comment 11

19 years ago
reassigning to jfrancis. Joe you may want to get Kin to help out on this one if
you need assistance.

Updated

19 years ago
Assignee: jfrancis → saari

Comment 12

19 years ago
Chris, the non-xp nature also doens't point to an editor problem.  So that's
neither here nor there.

Anyway, the characters are _not_ showing up at the right place on linux.  That
seems like a focus problem, and is the worst part of this bug.

I'll try to figure out why the caret isn't drawing on the mac.  Will you look
into the focus on linux?  reassigning to sarri.
(Assignee)

Updated

19 years ago
Status: NEW → ASSIGNED
(Assignee)

Comment 13

19 years ago
Okay, I'll look at the linux issue. Thanks for the help!

Updated

19 years ago
Target Milestone: M13 → M14

Comment 14

19 years ago
No time for this level of bug in M13, moving to m14

Updated

19 years ago
Keywords: pp
(Assignee)

Updated

19 years ago
Keywords: beta1
(Assignee)

Comment 15

19 years ago
Okay, I think I've fixed this now. At least, characters appeared by the cursor 
:-)
Status: ASSIGNED → RESOLVED
Last Resolved: 19 years ago
Resolution: --- → FIXED

Updated

19 years ago
QA Contact: lchiang → esther
(Reporter)

Comment 16

19 years ago
Using build 2000-05-16-09 on win98, mac and linux the carat/cursor is correctly 
placed in the 1st addressing field when clicking on New Msg and this field has 
focus.  Verified.
Status: RESOLVED → VERIFIED
Product: MailNews → Core
Product: Core → MailNews Core
You need to log in before you can comment on or make changes to this bug.