random crashes while: typing in mail; browsing on web; clicking a link; retrieving mail

RESOLVED WORKSFORME

Status

--
critical
RESOLVED WORKSFORME
15 years ago
10 years ago

People

(Reporter: daniel.lee.kruse, Assigned: mkaply)

Tracking

({crash})

Trunk
x86
OS/2
crash

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

15 years ago
User-Agent:       Mozilla/5.0 (OS/2; U; Warp 4.5; en-US; rv:1.5b) Gecko/20030825
Build Identifier: Mozilla/5.0 (OS/2; U; Warp 4.5; en-US; rv:1.5b) Gecko/20030825

Mozilla 5.1a/b have crashed on these uses:
* typing in the edit area in the mail component
* just browsing the web.  there haven't been any particular sites that are the
cause.  it is totally random when it does it.
* clicking a href link will cause random crashes.  this, too, isn't tied to a
particular web site.
* retrieving mail will randomly cause the browser to crash.


Reproducible: Sometimes

Steps to Reproduce:
I wish it was consistent enough to reproduce but is very random.

Actual Results:  
Sometimes the action works, sometimes the action causes the browser to crash. 
The crashing is the only consistent event.

Expected Results:  
Not crashed.


09-06-2003  08:53:32  SYS3175  PID 0036  TID 0003  Slot 007e
D:\APPS\WEB\MOZILLA.ORG\MOZILLA1.5B\MOZILLA.EXE

SOFTOKN3.DLL 0001:00017305

------------------------------------------------------------

09-06-2003  12:09:34  SYS3175  PID 0038  TID 0001  Slot 0079
GKLAYOUT.DLL 0001:002562a3

------------------------------------------------------------

09-06-2003  16:10:41  SYS3175  PID 003a  TID 0001  Slot 0079
XPCONECT.DLL 0001:00029207

------------------------------------------------------------

09-06-2003  16:11:04  SYS3175  PID 003c  TID 0001  Slot 0079
D:\APPS\WEB\MOZILLA.ORG\MOZILLA1.5B\MOZILLA.EXE

XPCOM.DLL 0001:0006e801

------------------------------------------------------------

09-06-2003  22:56:10  SYS3175  PID 0038  TID 001a  Slot 0096
D:\APPS\WEB\MOZILLA.ORG\MOZILLA1.5B\MOZILLA.EXE
JITC.DLL 0001:0014aaee

------------------------------------------------------------

09-07-2003  12:53:48  SYS3175  PID 0036  TID 0001  Slot 0079
D:\APPS\WEB\MOZILLA.ORG\MOZILLA1.5B\MOZILLA.EXE

XPCONECT.DLL 0001:000291ef

------------------------------------------------------------

09-07-2003  20:11:01  SYS3175  PID 0039  TID 0001  Slot 0079
D:\APPS\WEB\MOZILLA.ORG\MOZILLA1.5B\MOZILLA.EXE
NPSWF2.DLL 0002:00044305

------------------------------------------------------------

09-07-2003  20:28:31  SYS3175  PID 003c  TID 0001  Slot 0079
D:\APPS\WEB\MOZILLA.ORG\MOZILLA1.5B\MOZILLA.EXE
XPCOM.DLL 0001:0005b9fa

------------------------------------------------------------

09-07-2003  21:51:50  SYS3175  PID 003f  TID 0001  Slot 0079
D:\APPS\WEB\MOZILLA.ORG\MOZILLA1.5B\MOZILLA.EXE

GKLAYOUT.DLL 0001:0024eb0d

------------------------------------------------------------

09-07-2003  21:52:01  SYS3175  PID 0040  TID 0001  Slot 0079
D:\APPS\WEB\MOZILLA.ORG\MOZILLA1.5B\MOZILLA.EXE
XPCOM.DLL 0001:0006e801


[C:\]help sys3175

SYS3175: A program in this session encountered a problem and
cannot continue.

EXPLANATION: An access violation exception occurred and was generated
when an attempt was made either to load or store data in an inaccessible
location or to execute an inaccessible instruction.  This exception
corresponds to both the Intel 80386 processor general protection fault
(#13), caused by an invalid access attempt, and the page fault (#14),
caused by an attempt to access an uncommitted page or a page with
incorrect attributes for the desired operation.

ACTION: If you purchased this program, contact the supplier of the
program.  If you are the developer of this program, refer to the
information in the register.
(Reporter)

Comment 1

15 years ago
Created attachment 131052 [details]
dumps of mozilla 1.5b

Updated

15 years ago
Keywords: crash
OS: other → OS/2
These are resolved with 1.5.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → WORKSFORME
(Reporter)

Comment 3

15 years ago
Found the problem.  As I would load more programs into RAM is when it was
occurring.  I ran Memtest86 on my machine which revealed I had several locations
that were bad.  So it was a hardware problem and not Mozilla at all.
Product: Core → Core Graveyard
You need to log in before you can comment on or make changes to this bug.