No OpenBSD support for IPv6

RESOLVED FIXED in 4.5

Status

NSPR
NSPR
RESOLVED FIXED
15 years ago
14 years ago

People

(Reporter: Paul de Weerd, Assigned: Darin Fisher)

Tracking

4.4.1
x86
OpenBSD

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

15 years ago
User-Agent:       Mozilla/5.0 (X11; U; OpenBSD i386; en-US; rv:1.5a) Gecko/20030908 Mozilla Firebird/0.6.1
Build Identifier: Mozilla/5.0 (X11; U; OpenBSD i386; en-US; rv:1.5a) Gecko/20030908 Mozilla Firebird/0.6.1

When trying to connect to a website with an IPv6 address (such as
http://www.kame.net/ , http://www.ipng.nl/ or http://www.sixxs.net/ ) firebird
refuses to connect over IPv6 and uses IPv4 instead. For sites that do not have
an IPv4 address firebird can not connect at all.

I noticed that Firebird does not even resolve quad-A records (IN AAAA) for
hostnames entered as URLs. However, Firebird also does not connect when given
the IP address explicitly (within []'s) and instead appears to search the web
for a page containing the given URL (go to http://[2001:6e0::250:4ff:fe4a:7708]/
for an example)

Reproducible: Always

Steps to Reproduce:
1. Install the latest OpenBSD snapshot
2. Install the mozilla-firebird port using the portstree
3. Open firebird and visit an IPv6-enabled website such as http://www.kame.net/

Actual Results:  
Firebird connects over IPv4 (to 203.178.141.194)

Expected Results:  
Firebird should connect over IPv6 (to 2001:200:0:8002:203:47ff:fea5:3085). On
http://www.kame.net/ a 'dancing kame' should be shown in stead of the static
kame you see when connecting over IPv4.
spoke to timeless on IRC, there may not even be any IPv6 code for OpenBSD in
Mozilla.
Assignee: blake → wchang0222
Component: General → NSPR
Product: Firebird → NSPR
QA Contact: asa → wchang0222
Summary: Firebird does not connect to IPv6-enabled hosts (does not even try to resolve a AAAA address) → No OpenBSD support for IPv6
Version: unspecified → 4.4.3

Comment 2

15 years ago
Darin, could you take care of this?  I suspect you can
use the code in pr/include/md/{_freebsd.h,_netbsd.h} as
an example for _openbsd.h.
Assignee: wchang0222 → darin
Status: UNCONFIRMED → NEW
Ever confirmed: true
(Reporter)

Comment 3

15 years ago
I have just installed Firebird 0.7 on my system. Unfortunately there's still no
IPv6 support.
(Reporter)

Comment 4

14 years ago
Today I upgraded two workstations to the latest -current version of OpenBSD. I 
also installed all ports again, upgrading firebird to an unofficial firefox 
port. Unfortunately firefox also does not allow me to visit IPv6-enabled 
websites. Still no AAAA records are queried for hosts I want to visit.

I'm hoping for 1.0 ;)

Comment 5

14 years ago
We added code to enable IPv6 support in NSPR for
OpenBSD on 2004-03-10.

Could someone test IPv6 with a Mozilla nightly build
dated 2004-03-11 or later, or Mozilla 1.7 beta or
later on OpenBSD?
(Reporter)

Comment 6

14 years ago
The following diff (as found in a posting from Waldemar Brodkorb to the OpenBSD
ports mailinglist; see
http://marc.theaimsgroup.com/?l=openbsd-ports&m=107775193605517&w=2 for his
posting) fixes the issue with firefox 0.8. That is to say, with this patch I can
connect to IPv6 sites and everything appears to function correctly (have not
found any problems yet).

I hope this can be integrated in the source.

$OpenBSD$                                                                      
                          
--- nsprpub/pr/include/md/_openbsd.h.orig       2004-02-25 14:29:55.000000000
+0100                       
+++ nsprpub/pr/include/md/_openbsd.h    2004-02-25 14:30:35.000000000 +0100    
                          
@@ -60,6 +60,12 @@                                                             
                          
 #define _MD_DEFAULT_STACK_SIZE 65536L                                         
                          
 #define _MD_MMAP_FLAGS          MAP_PRIVATE                                   
                          
                                                                               
                          
+#define _PR_INET6                                                             
                          
+#define _PR_HAVE_INET_NTOP                                                    
                          
+#define _PR_HAVE_GETHOSTBYNAME2                                               
                          
+#define _PR_HAVE_GETADDRINFO                                                  
                          
+#define _PR_INET6_PROBE                                                       
                          
+                                                                              
                          
 #undef  HAVE_STACK_GROWING_UP                                                 
                          
 #define HAVE_DLL                                                              
                          
 #define USE_DLFCN                                                             
                          

Comment 7

14 years ago
Paul: thank you for pointing out the patch and
verifying that it works.

That patch is exactly the new code I mentioned
(in comment 5).  So I am marking this bug fixed.
That patch will be in Mozilla 1.7 beta.  I don't
know when it will appear in Firefox because I
don't follow Firefox development.
Status: NEW → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → FIXED
Target Milestone: --- → 4.5
Version: 4.4.3 → 4.4.1
You need to log in before you can comment on or make changes to this bug.