dynamic font support as recommended by the w3c

RESOLVED DUPLICATE of bug 52746

Status

Core Graveyard
GFX: Xlib
--
enhancement
RESOLVED DUPLICATE of bug 52746
15 years ago
10 years ago

People

(Reporter: Mario Salzer, Assigned: Roland Mainz)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

15 years ago
User-Agent:       Mozilla/5.0 (MSIE/6.0; compatible; Win98)
Build Identifier: all versions

There once were that .pfr fonts available for Communicator/Navi 4. While
these happily disappeared and Macrosafts .eot's did not gain much more
momentum until today, the w3c nevertheless recommended such dynamic fonts
as extensions to HTML and CSS. They also stated it would be fine, if .ttf
and .pfb and some others were supported.

This is obviously a simple task if a Gecko browser runs below a X11 Server,
as all that is to do would be loading the font, saving it to a temporary
font directory ($HOME/.rc/mozilla/dfonts/ for example) and then redirecting
the X11 font server to see it:

xset +fp $HOME/.rc/mozilla/dfonts/    # if not already done
xset fp rehash                        # making any .ttf or .pfb font available

This is a stupids` approach, and I believe there is a much easier and saner
possibility in the Xlib interface to do so. And wasn't there some other
font library already loaded into the mozilla binary??

As you probably already know, many people would like to see support for
this at some point :)


Thanks,
mario

Reproducible: Always

Steps to Reproduce:
1.
2.
3.

Comment 1

15 years ago
Please search for duplicates before opening a bug.

*** This bug has been marked as a duplicate of 52746 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → DUPLICATE

Updated

11 years ago
Blocks: 407316
Product: Core → Core Graveyard
You need to log in before you can comment on or make changes to this bug.