If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

composer rewrites colors from hex to rgb, rewrites <br /> to <br> in XHTML documents, inserts extra line breaks on document open

VERIFIED DUPLICATE of bug 218678

Status

SeaMonkey
Composer
--
major
VERIFIED DUPLICATE of bug 218678
14 years ago
13 years ago

People

(Reporter: Aleksey Lazar, Unassigned)

Tracking

Trunk
x86
Windows XP

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

14 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.5b) Gecko/20030827
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.5b) Gecko/20030827

As soon as an XHTML file is opened composer rewrites ALL inline style defined
colors from HEX to RGB. This (and what follows) happens even is I specify in
Preferences NOT to rewrite the code. Along with that "feature" all X(HT)ML
breaks - <br /> are changed to <br>. On top of all of that it adds and deletes
line breaks, basically reformatting the whole document, along with removing the
<xml> line from the top of the page. This a source of major unhappiness,
especially the <br>s and line break freakiness. I made a small XHTML file to
display this.

Reproducible: Always

Steps to Reproduce:
1. Open http://www.mnsu.edu/aleksey/index.html
2. Go to File>Edit Page
3. Click <HTML> Source tab at the bottom
4. Witness the changes.

Actual Results:  
Mutilated code:

<html xmlns="http://www.w3.org/1999/xhtml"><head><title>MSU Colors</title>

<meta content="text/html; charset=iso-8859-1" http-equiv="Content-Type">
<link type="text/css" rel="stylesheet" href="colors.css"></head>


<body>
<div style="background-color: rgb(248, 232, 49); color: rgb(0, 0, 0);"><p>MSU
Golden Yellow<br>
Hex: #F8E831<br>
RGB: 248, 232, 49</p></div>
</body></html>

Expected Results:  
Left everything the way it was:
<?xml version="1.0" encoding="iso-8859-1"?>
<!DOCTYPE html PUBLIC "-//W3C//DTD XHTML 1.0 Strict//EN"
"http://www.w3.org/TR/xhtml1/DTD/xhtml1-strict.dtd">
<html xmlns="http://www.w3.org/1999/xhtml">
<head>
<title>MSU Colors</title>
<meta http-equiv="Content-Type" content="text/html; charset=iso-8859-1" />
<link href="colors.css" rel="stylesheet" type="text/css" />
</head>
<body>
<div style="background-color: #f8e831; color: #000;"><p>MSU Golden Yellow<br />
Hex: #F8E831<br />
RGB: 248, 232, 49</p></div>
</body>

</html>

Am I missing some option somewhere in Preferences?? (Besides the "Retain
original source formatting" which is on?
(Reporter)

Comment 1

14 years ago

*** This bug has been marked as a duplicate of 218678 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → DUPLICATE

Comment 2

14 years ago
.
Status: RESOLVED → VERIFIED
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.