empty space above each tab in tab bar

RESOLVED DUPLICATE of bug 624225

Status

()

Firefox
Toolbars and Customization
--
minor
RESOLVED DUPLICATE of bug 624225
15 years ago
5 years ago

People

(Reporter: Jesse Ruderman, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

15 years ago
Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.5b) Gecko/20030908
Firebird/0.6.1+

There is empty space above tabs (1px for the active tab, 3px for other tabs) in
the default theme.

Current behavior:  double-clicking in that space opens a new tab.
Expected behavior: single-clicking in that space should select the tab it's above.
(Reporter)

Comment 1

15 years ago
I filed this bug because I accidentally double-clicked in one of these tiny
spaces while trying to switch tabs.  (I think I clicked once, noticed it didn't
switch, and clicked again quickly without moving the cursor down enough.)

Comment 2

15 years ago
The amount of space is theme dependant, modern has 1px above all tabs. I don't
think it should make a difference, but thought I would note it in case.
This is theme-specific.  The height of the tabs is intentionally leas than the
height of the tab bar in the default theme.  MicroFirebird 1.6 has no such spaces. 

I don't think this (correct) behaviour needs to be changed at all, since you're
anticipating someone accidentally double-clicking on a spot that isn't a tab,
thinking it IS a tab, which is an edge case.  Also, fixing this involves having
code specifically to handle a click that isn't over an element to apply to an
element, which really sets a bad precedent.  Why not have a 3px "grace area"
around form elements on web pages for those times where people aren't accurate
enough with their mouse?
(Reporter)

Comment 4

15 years ago
> I don't think this (correct) behaviour needs to be changed at all, since
> you're anticipating someone accidentally double-clicking on a spot that isn't 
> a tab, thinking it IS a tab, which is an edge case.

It is an edge case, but it's an edge case that I have hit.  Also, it's not that
I *thought* the strip was part of the tab.  I just clicked there accidentally
while trying to click the tab.

The problem here is that missing leads to a behavior that is completely
unexpected and hard to reproduce (kind of like bug 153766).  I don't understand
how you can think it's "correct" for double-clicking a tiny strip above a tab to
open a new tab.  Doing nothing would be reasonable, but opening a new tab is not
reasonable.

> Also, fixing this involves having code specifically to handle a click that 
> isn't over an element to apply to an element, which really sets a bad 
> precedent.

Or there could be an invisible box around the tab, and the invisible box could
handle clicks.

> Why not have a 3px "grace area" around form elements on web pages for those 
> times where people aren't accurate enough with their mouse?

Sure, why not?  Internet Explorer has a 4px "grace area" around checkboxes.
*** Bug 274890 has been marked as a duplicate of this bug. ***
Dropping a URL up there also opens a new tab, per the dup.

Contrariwise, I've actually used that space, in the buggy situation with too
many tabs to fit on the bar, when that's the only blank-tabbar space that exists
as a drop or double-click target.
Depends on: 277549
No longer depends on: 277549

Updated

13 years ago
Assignee: hyatt → nobody
QA Contact: bugzilla → toolbars
(Reporter)

Comment 7

12 years ago
See also bug 312896, a semi-dup.
I'm hit by that bug often too. I think including such "operism" (non-standard wierd behaviour) into browser was mistake in first place. Ff has customize dialog allowing to put "New Tab" button almost everywhere. It doesn't need such CUI (common user interface) non-conformat hack/behaviour.

If I click on Tab - hoping to activate it - but miss and click second time, most of the time I trigger creation of another tab.

If I click on close tab button - but miss and click second time, most of the time I trigger creation of another tab, what is 100% different of what I tried to achieve.

P.S. related to bug 312896 and bug 320601

Anyway, as I am concerned, making an option for the freaking "double-click to open new Tab" action would solve problem for me.

Also, GUI-wise, and as the bug really concerned, proper solution would be to create a panel spanning free space in Tab pane. And then hang the current double click action on that pane - instead of parent pane holding all the tabs, as it is done now.

Comment 9

8 years ago
If Firefox 3.7 incorporates a "tabs on top" interface, the empty space above the tabs should definitely be removed, especially in fullscreen mode, so users can quickly switch tabs (according to Fitt's Law).

Also, double-clicking on the empty space to create a new tab is confusing for most users, because it is a poorly documented feature.

By the way, does anyone know of the bug for the "tabs on top" interface? Has one been created yet?

Comment 10

7 years ago
With Firefox 4 and tabs on top this bug became really annoying. 
There are twelve pixels between tabs on the first row above them that acts like the tab bar.
Is it possible to make an option to disable the "middle click on tab bar opens new tab" behaviour?
or fix the bug instead.

Comment 11

7 years ago
I report the advice of user KWierso:
"I'm using Stylish to get rid of the tabs' border-radius, which gets rid of the problem with the corners of the tabs:
#TabsToolbar .tabbrowser-tab { border-radius: 0 !important; }"

Updated

5 years ago
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 624225
You need to log in before you can comment on or make changes to this bug.