The default bug view has changed. See this FAQ.

mailnews crashes when going online after being offline [@ morkArray::CloseArray]

VERIFIED FIXED

Status

SeaMonkey
MailNews: Backend
--
critical
VERIFIED FIXED
14 years ago
13 years ago

People

(Reporter: Stefan Magdalinski, Assigned: Bienvenu)

Tracking

({crash, regression})

Trunk
x86
Windows XP
crash, regression

Firefox Tracking Flags

(Not tracked)

Details

(crash signature)

Attachments

(2 attachments)

1.17 KB, patch
(not reading, please use seth@sspitzer.org instead)
: review+
Scott MacGregor
: superreview+
(not reading, please use seth@sspitzer.org instead)
: approval1.5+
Details | Diff | Splinter Review
661 bytes, patch
Details | Diff | Splinter Review
(Reporter)

Description

14 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Win98; en-US; rv:1.5b) Gecko/20030827
Build Identifier: Mozilla/5.0 (Windows; U; Win NT 5.1; en-US; rv:1.5b) Gecko/20030901


see steps to reproduce. There should be some talkback logs around to with

"switching from working offline to online" in the browser URL field (wrong place
I know, sorry)

Reproducible: Always

Steps to Reproduce:
1. start mailnews.
2. go offline (ALT f l w)
3. go online (ALT f l w again)
4. When asked if you wish to send Unsent messages (if you have some... this may
be relevant - I haven't tried without), select "Don't send"




Actual Results:  

kaboom! 

Expected Results:  

gone online.

Comment 1

14 years ago
Reporter, could you please post the Talkback ID for the incident? You'll find
the ID if you start talkback (run "talkback.exe").
URL:
Keywords: crash
(Reporter)

Comment 2

14 years ago
ok. try

TB23435431M
TB23434977X

(Assignee)

Comment 3

14 years ago
Stefan, I can't reach talkback to see the stacktraces. Can you send me your
prefs.js? There must be something about your configuration that's causing the
crash because this works fine for me. Thx.
Status: UNCONFIRMED → NEW
Ever confirmed: true
(Reporter)

Comment 4

14 years ago
Bienvenu: I emailed you my prefs.

also, this only seems to occur if you choose NOT to send your unsent messages
when going online. If you send the messages, or don't have any waiting to be
sent, it's ok.


(Assignee)

Comment 5

14 years ago
Created attachment 131183 [details] [diff] [review]
proposed fix

this will fix the problem. I have another patch to fix the underlying problem
in the msg db & dbfolderinfo code, but this fix is safer for 1.5
(Assignee)

Comment 6

14 years ago
thx to seth for the stack trace:

0x0927802d
morkArray::CloseArray [c:/builds/seamonkey/mozilla/db/mork/src/morkArray.cpp,
line 135]
morkArray::CloseMorkNode [c:/builds/seamonkey/mozilla/db/mork/src/morkArray.cpp,
line 73]
morkTable::CloseTable [c:/builds/seamonkey/mozilla/db/mork/src/morkTable.cpp,
line 190]
morkTable::CloseMorkNode [c:/builds/seamonkey/mozilla/db/mork/src/morkTable.cpp,
line 100]
morkTable::~morkTable [c:/builds/seamonkey/mozilla/db/mork/src/morkTable.cpp,
line 108]
morkTable::`scalar deleting destructor'
morkObject::Release [c:/builds/seamonkey/mozilla/db/mork/src/morkObject.cpp,
line 68]
nsDBFolderInfo::ReleaseExternalReferences
[c:/builds/seamonkey/mozilla/mailnews/db/msgdb/src/nsDBFolderInfo.cpp, line 279]
nsDBFolderInfo::Release
[c:/builds/seamonkey/mozilla/mailnews/db/msgdb/src/nsDBFolderInfo.cpp, line 151]
nsImapOfflineSync::ProcessNextOperation
[c:/builds/seamonkey/mozilla/mailnews/imap/src/nsImapOfflineSync.cpp, line 663]

Status: NEW → ASSIGNED
(Assignee)

Updated

14 years ago
Attachment #131183 - Flags: superreview?(scott)
(Assignee)

Comment 7

14 years ago
there are a couple extra lines in that patch that are for a separate problem -
they don't do anything at the moment, so they're harmless.

Comment 8

14 years ago
Comment on attachment 131183 [details] [diff] [review]
proposed fix

I don't understand your fix David =). Isn't this just a no-op? 

if (!imapInbox)
{
}

there is no else clause so the statements that follow will still be executed.

Updated

14 years ago
Attachment #131183 - Flags: superreview?(scott) → superreview+
(Assignee)

Comment 9

14 years ago
Created attachment 131184 [details] [diff] [review]
fix underlying problem - for 1.6

this fixes the underlying problem
Comment on attachment 131183 [details] [diff] [review]
proposed fix

r/a of that one line for 1.5:

+folderInfo = nsnull; // can't hold onto folderInfo longer than db

thanks david.
Attachment #131183 - Flags: review+
Attachment #131183 - Flags: approval1.5+
(Assignee)

Comment 11

14 years ago
fixed
Status: ASSIGNED → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → FIXED
(Assignee)

Comment 12

14 years ago
adding regression keyword
Keywords: regression

Updated

14 years ago
Summary: mailnews crashes when going online after being offline → mailnews crashes when going online after being offline [@ morkArray::CloseArray]
(Assignee)

Comment 13

14 years ago
Stefan, thx. Please try tomorrow's mozilla build and let me know if this is
fixed for you.
(Reporter)

Comment 14

14 years ago
verified with 

Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.5b) Gecko/20030910
Status: RESOLVED → VERIFIED
Product: Browser → Seamonkey
Crash Signature: [@ morkArray::CloseArray]
You need to log in before you can comment on or make changes to this bug.