Unclosed FONT tags cause Mozilla to show some links as usual text (not a link)

VERIFIED DUPLICATE of bug 58917

Status

()

Core
HTML: Parser
VERIFIED DUPLICATE of bug 58917
14 years ago
14 years ago

People

(Reporter: virtan, Unassigned)

Tracking

Trunk
x86
Linux
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

14 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.4) Gecko/20030624
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.4) Gecko/20030624

If we cycle the code "[a href=x][font]abc[/a]" (square brackets must be replaced
by angle ones) for more than 199 times we get following situation:
Mozilla correctly closes unclosed FONT tags until we reach entry 199;
since this magic entry Mozilla starts to close A tag immediately after opening it.

Reproducible: Always

Steps to Reproduce:
1. generate html page with code "[a href=x][font]abc[/a]" (square brackets must
be replaced by angle ones) cycled for more than 199 times
2. view it in Mozilla
3. try to click link in entry 199 or more

Actual Results:  
Links since entry 199 became usual text (not linked)

Expected Results:  
Text inside opening and closing tags of A must be shown as link in any case.
(Reporter)

Comment 1

14 years ago
Created attachment 131123 [details]
bug reproduction

Comment 2

14 years ago

*** This bug has been marked as a duplicate of 58917 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 14 years ago
Component: Layout: Fonts and Text → Parser
Resolution: --- → DUPLICATE

Comment 3

14 years ago
v.
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.