NTLM http authorization crashes program upon user/pass submittal

RESOLVED DUPLICATE of bug 212336

Status

()

--
critical
RESOLVED DUPLICATE of bug 212336
15 years ago
15 years ago

People

(Reporter: jaciss, Assigned: darin.moz)

Tracking

({crash})

Trunk
x86
Windows 98
crash
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

15 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Win98; en-US; rv:1.5b) Gecko/20030908
Build Identifier: Mozilla/5.0 (Windows; U; Win98; en-US; rv:1.5b) Gecko/20030908

Upon calling a page requiring authorization, the "prompt" window appears, asking
for user/pass combination as expected ('enter username and password for "" at
website.org').  If canceled, "you are not authorized" also shows as expected. 
However, if anything is entered in the boxes, Mozilla crashes.

Reproducible: Always

Steps to Reproduce:
1. Start Mozilla
2. Type http://talamhlore.org/admin into browser bar and hit enter
3. Enter user/pass into form and submit

Actual Results:  
Mozilla crashes with message: invalid page fault in module SECUR32.dll at
0167:7f8737da

Expected Results:  
Authorized user and shown requested page

invalid page fault in module SECUR32.dll at 0167:7f8737da
Site is having DNS issues, but same problem occurs when using IP instead of
domain name
Using LiteStep shell replacement, though that doesn't appear to be the issue

Comment 1

15 years ago
Reporter: Could you provide TalkBack incident IDs of your crashes?

WFM 2003090809/trunk/W2K
Keywords: crash

Comment 2

15 years ago
WFM Win2k 2003082704 (beta release)

Comment 3

15 years ago
This looks the same as bug 212336, even though that one seems to deal with NTLM
auth, not necessarily basic.  Specifically, see the error message text in bug
212336 comment 20.

David
(Assignee)

Comment 4

15 years ago
you are using NTLM, not Basic auth.  probably the server challenges with both
NTLM and Basic, and since you upgraded to a newer mozilla, we choose to respond
to the NTLM challenge.  unfortunately, it seems that certain Win98 versions have
a poorly behaving Secur32.dll, or possibly we are just not talking to it
correctly.  definitely a duplicate of bug 212336.

*** This bug has been marked as a duplicate of 212336 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → DUPLICATE
Summary: basic http authorization crashes program upon user/pass submittal → NTLM http authorization crashes program upon user/pass submittal
You need to log in before you can comment on or make changes to this bug.