Spell Checker on, Ctrl+Return invokes confirmation dialog before spell checking

NEW
Unassigned

Status

SeaMonkey
MailNews: Message Display
--
minor
14 years ago
2 years ago

People

(Reporter: Andrew, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

14 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.5b) Gecko/20030827
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.5b) Gecko/20030827

If one has the "Check spelling before sending" option turned on and after
composing a message, sends it via Ctrl+Return rather than clicking the Send
button or choosing the File|Send Now menu, they see an extra dialog that
probably shouldn't be there and is confusing.  The dialog asks them if they are
ready to send the message, and clicking Send invokes the Spell Checker.  This
seems out of place. 

Reproducible: Always

Steps to Reproduce:
1. Compose a message
2. Clearly spell a word wrong
3. Hit ctrl-return to send
4. Send Message dialog: click Send

Actual Results:  
Spell checker invokes

Expected Results:  
This is confusing.  Why do I click "Send" on this dialog only to have the spell
checker invoked?  Why does this dialog only show when ctrl+return is hit, and
not when the Send or File | Send Now/Send Later options are invoked?

Yes, I know I can check the box to not show the dialog again, but why is it
there in the first place?

Classic Theme, Mozilla 1.5b on Windows 2000
> Why does this dialog only show when ctrl+return is hit

Because of a lamentable tendency to trigger that keybinding without knowing it
exists (and accidentally send mail) that people seem to have...

Sounds like the order of the dialogs should be reversed here.
Status: UNCONFIRMED → NEW
Ever confirmed: true

Updated

14 years ago
QA Contact: esther → core.spelling-checker
Product: Browser → Seamonkey

Updated

13 years ago
Assignee: sspitzer → mail

Comment 2

11 years ago
(In reply to comment #1)
>...
> Sounds like the order of the dialogs should be reversed here.

not sure I agree.

the dialog is due to the preference setting 
  Confirm when using keyboard shortcut to send message

Now, with "spell check before sending" turned on there's probably no need for the confirmation, but that's the user's choice. To me, with both preferences turned on, it seems natural that the confirmation dialog appear BEFORE the spell check is invoked.

should this be closed INVALID?
OS: Windows 2000 → All
QA Contact: spelling-checker
Hardware: PC → All
Summary: Spell Checker on, Ctrl+Return invokes extra dialog before spell checking → Spell Checker on, Ctrl+Return invokes confirmation dialog before spell checking
You need to log in before you can comment on or make changes to this bug.