If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

<xml-stylesheet> processing instruction with href pointing to missing file makes some attributes get ignored in XUL file

RESOLVED DUPLICATE of bug 218764

Status

()

Core
XML
--
minor
RESOLVED DUPLICATE of bug 218764
14 years ago
14 years ago

People

(Reporter: Cedric. S., Assigned: Heikki Toivonen (remove -bugzilla when emailing directly))

Tracking

Trunk
x86
Windows 2000
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

14 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.4) Gecko/20030624
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.4) Gecko/20030624

In the example file below, if "toto.css" does not exist, width & height
attributes of the window object are ignored and the window takes the whole
screen (debug attribute is correctly taken into account).

There is no message anywhere about the missing file "toto.css".

This is visible when displying the window with "mozilla --chrome...", not when
opening it in a tab of the browser.

I am not sure if this is an XML problem or a XUL problem.

Its not blocking (just remove the line referencing inexistant file), but the
fact that attributes are ignored may denote a deeper problem ?

Reproducible: Always

Steps to Reproduce:
1. put the attached xul code in file (say test.xul) in on chrome directory
2. execute "mozilla --chrome chrome://mychrome/content/test.xul"
Actual Results:  
widht and height attributes are ignored on the window object and the window is
displayed full screen

Expected Results:  
the window is displayed at 640x480 ;
potentially a message on the console indicates that there is a reference to
a missing file in the PI

<?xml version="1.0"?>
<?xml-stylesheet href="toto.css" type="text/css"?>
<!-- toto.css does not exist in the same directory than the XUL file -->
<window
  xmlns="http://www.mozilla.org/keymaster/gatekeeper/there.is.only.xul"
  debug="true" width="640px" height="480px">

</window>
(Reporter)

Comment 1

14 years ago
This submission is an error of my part (reload on the browser).
sorry for this.
Please Ignore it.

*** This bug has been marked as a duplicate of 218764 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.