Java (I think) causes crash in v1.5b but not v1.4

RESOLVED WORKSFORME

Status

Core Graveyard
Java: OJI
--
critical
RESOLVED WORKSFORME
14 years ago
7 years ago

People

(Reporter: Sam Little, Assigned: Joshua Xia)

Tracking

({crash})

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

14 years ago
User-Agent:       Mozilla/5.0 (OS/2; U; Warp 4.5; en-US; rv:1.5b) Gecko/20030825
Build Identifier: Mozilla/5.0 (OS/2; U; Warp 4.5; en-US; rv:1.5b) Gecko/20030825

Signing into the Sun Web Learning Center, once signed in, always crashes loading
the first page following under this version of Mozilla (and IBM Java(TM)
Plug-in: J2RE 1.3.1 IBM build co131-20030618), but Mozilla 1.4 does not have the
same problem.

Popuplog.os2 shows:

09-10-2003  01:38:04  SYS3173  PID 004a  TID 0001  Slot 00bf
G:\MOZILLA\MOZILLA.EXE
c000009f
1d1f0118
EAX=00000000  EBX=0006f9ac  ECX=00000000  EDX=1a637020
ESI=02672070  EDI=1d1f8f4c  
DS=0053  DSACC=d0f3  DSLIM=bfffffff  
ES=0053  ESACC=d0f3  ESLIM=bfffffff  
FS=150b  FSACC=00f3  FSLIM=00000030
GS=0000  GSACC=****  GSLIM=********
CS:EIP=005b:1d1f0118  CSACC=d0df  CSLIM=bfffffff
SS:ESP=0053:0006f95c  SSACC=d0f3  SSLIM=bfffffff
EBP=0006f95c  FLG=00202246

IPLUGINW.DLL 0001:00000118


Reproducible: Always

Steps to Reproduce:
1. Go to https://tmn.sun.com/WLC/Login?
2. Enter name and password
3. Watch page load.

Actual Results:  
Exception (SYS3173) thrown and Mozilla closes near the end of page loading.

Expected Results:  
Finished loading.

Under both 1.4 and 1.5b, Mozilla halts for 15-20 seconds while loading (rolling
icons stop rolling), presumably while JVM is loading. Crash occurs after VM is
open but before page loads completely.

Exception in IPLUGINW.DLL is consistent. On two occasions (of five), a second,
almost simultaneous exception was thrown -- a SYS3175 in JV12MI36.DLL 0002:0001603c.

Not all pages with Java crash, so I'm not sure what the exact trigger is.

Updated

14 years ago
Severity: normal → critical
Keywords: crash
OS: other → OS/2

Comment 1

14 years ago
->oji
Assignee: peterlubczynski-bugs → joshua.xia
Component: Plug-ins → OJI

Comment 2

14 years ago
I got the crash in the java vm loading process with:
http://adsl.internode.on.net/speedtest/
http://www.unitedlinux.com/
Mozilla 1.5b
Mozilla/5.0 (X11; U; Linux i586; en-US; rv:1.5b) Gecko/20030908
java version "1.4.2"
Java(TM) 2 Runtime Environment, Standard Edition (build 1.4.2-b28)
Java HotSpot(TM) Client VM (build 1.4.2-b28, mixed mode)
Do you still see this with 1.5rc1?  This newer build contains updated to
IPLUGINW.DLL.
(Reporter)

Comment 4

14 years ago
Well... the crash has moved from ipluginw.dll to jvm.dll, in much the same place:

09-26-2003  13:26:56  SYS3175  PID 00c9  TID 0007  Slot 00bd
G:\MOZILLA\MOZILLA.EXE
c0000005
133fe8f1
P1=00000000  P2=ffffffff  P3=XXXXXXXX  P4=XXXXXXXX  
EAX=ffffffff  EBX=02a57225  ECX=02a531ec  EDX=02a57224
ESI=ffffffff  EDI=0279f5f4  
DS=0053  DSACC=d0f3  DSLIM=bfffffff  
ES=0053  ESACC=d0f3  ESLIM=bfffffff  
FS=150b  FSACC=00f3  FSLIM=00000030
GS=0000  GSACC=****  GSLIM=********
CS:EIP=005b:133fe8f1  CSACC=d0df  CSLIM=bfffffff
SS:ESP=0053:0279f4ac  SSACC=d0f3  SSLIM=bfffffff
EBP=0279f54c  FLG=00012286

JVM.DLL 0001:0011e8f1

NOTE: Have since switched to Innotek's Java 1.4.2_01 plugin, which does work
properly.

Comment 5

14 years ago
Do you still see this with 1.5?
(Reporter)

Comment 6

14 years ago
Yes. Switching back to IBM Java(TM) Plug-in: J2RE 1.3.1 IBM build co131-20030618
and following the instructions I gave added the following two entries to
popuplog.os2 (and Mozilla 1.5 closing).

11-01-2003  00:14:33  SYS3175  PID 0073  TID 0009  Slot 00b8
G:\MOZILLA\MOZILLA.EXE
c0000005
13b8e8f1
P1=00000000  P2=ffffffff  P3=XXXXXXXX  P4=XXXXXXXX  
EAX=ffffffff  EBX=02a17225  ECX=02a131ec  EDX=02a17224
ESI=ffffffff  EDI=028ff5f4  
DS=0053  DSACC=d0f3  DSLIM=bfffffff  
ES=0053  ESACC=d0f3  ESLIM=bfffffff  
FS=150b  FSACC=00f3  FSLIM=00000030
GS=0000  GSACC=****  GSLIM=********
CS:EIP=005b:13b8e8f1  CSACC=d0df  CSLIM=bfffffff
SS:ESP=0053:028ff4ac  SSACC=d0f3  SSLIM=bfffffff
EBP=028ff54c  FLG=00012286

JVM.DLL 0001:0011e8f1

------------------------------------------------------------

11-01-2003  00:14:33  SYS3170  PID 0073  TID 0001  Slot 00b5
G:\MOZILLA\MOZILLA.EXE
c0010002
1c03c491
P1=00000009  P2=XXXXXXXX  P3=XXXXXXXX  P4=XXXXXXXX  
EAX=028a6230  EBX=00000000  ECX=00000000  EDX=00000008
ESI=00000000  EDI=00000000  
DS=0053  DSACC=d0f3  DSLIM=bfffffff  
ES=0053  ESACC=d0f3  ESLIM=bfffffff  
FS=150b  FSACC=00f3  FSLIM=00000030
GS=0000  GSACC=****  GSLIM=********
CS:EIP=005b:13bd603c  CSACC=d0df  CSLIM=bfffffff
SS:ESP=0053:0013fc1c  SSACC=d0f3  SSLIM=bfffffff
EBP=0013fc54  FLG=00212202

DOSCALL1.DLL 0003:0000c491

Innotek's Java 1.4.2 implementations were working quite nicely for me until the
most recent, 1.4.2_02 (application/x-java-vm is correctly associated with a
plugin, but Mozilla behaves as though there isn't one and throws a pop-up
offering to search for a plugin for application/x-java-vm objects at Netscape).
I don't think this is a Mozilla problem, but a Innotek issue; it was just well
timed to get me to give 1.3.1 another try. ;-)
(Reporter)

Comment 7

14 years ago
This problem seems to be resolved in v1.6.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → WORKSFORME

Updated

7 years ago
Component: Java: OJI → Java: OJI
Product: Core → Core Graveyard
You need to log in before you can comment on or make changes to this bug.