dragging image into explorer does only work once

RESOLVED WORKSFORME

Status

()

Core
Drag and Drop
RESOLVED WORKSFORME
15 years ago
9 years ago

People

(Reporter: Nina Cording, Unassigned)

Tracking

({regression})

Trunk
x86
Windows ME
regression
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

15 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Win 9x 4.90; en-US; rv:1.5b) Gecko/20030908
Build Identifier: Mozilla/5.0 (Windows; U; Win 9x 4.90; en-US; rv:1.5b) Gecko/20030908

After dragging an (unlinked!) image into the explorer, only the first image
actually becomes a usable file.
All following dragged files have a size of 0KB, although they are named correctly.

Reproducible: Always

Steps to Reproduce:
1. Drag some (unlinked) images in an explorer folder
2. Refresh explorer window and notice the file sizes

Actual Results:  
Only the first dragged image is a usable file.
The following files were created with 0KB size.

Expected Results:  
Create a valid file for each drag'n'dropped image.

Comment 1

15 years ago
I just tried and couldn´t move any image off a website. Got an error message
from my german win98, something like: File can´t be moved. File system error (1026)

Can you give a link to a website, or did you view images from a local disk, or
local network? Did you drag multiple images, or just one after another?

Comment 2

15 years ago
Attempted to duplicate this bug using Windows 98 (First ed. as well as second)
with no success. Image drags fine and is displayed where expected. Firebird
build 0.6.1 (Perhaps a bug only resident in mozilla?)

256mb DDR, AMD Duron 1.3gHz, 80G HDD
Microsoft IntelliMouse

Comment 3

15 years ago
Regression: 1.4 and 1.4.1 working, Nightly not.

tested with 1.4, 1.4.1 and current nightly in this sequence in the same, simple
testprofile.
1.4 and 1.4.1 let me drag an image, and drop as link into an open folder in
windows explorer (right pane).
1.5b BuildID 2003091004 gives an error message in german, as I´m using a german
windows 98 (First edition, servicepack 1, some hotfixes)

Title: Fehler beim Verschieben der Datei
Body: Datei kann nicht verschoben werden. Dateisystemfehler (1026)

rough translation: can´t move file. file system error 1026


Nina, if you file a bug with Mozilla/5.0 (Windows; U; Win 9x 4.90; you should
select WinME in OS-Box, or do you see your bugs with win98, and file your bugs
with WinME?

Keywords: regression
(Reporter)

Comment 4

15 years ago
Some answers to my bug:
I did drag the images one after the other.
You can use any images, like the google-logo.

Sorry for selecting Win98. That's wrong and I changed it.
On the page for entering the bug (some kind of enter-the-bug-wizard?!)
there was no option for WinME, only for Win98, Win2000 and so on.
Well on THIS page, there is one. So I'll change that
That's good, because there are many differences between WinME and Win98
that can really be significant (i.E. registry entries,...)
OS: Windows 98 → Windows ME

Comment 5

15 years ago
Regression started with 1.5a?

retested today on another system, Win98SE.
dragging a gif with 1.4.1 produced a link in an windows explorer folder,
didn´t work with 1.5a, current nightly, build ID 2003081904.
Don´t have older versions of Mozilla on this computer.
Got same Windows Error (Dateisystemfehler (1026)) on this 512 MB win98SE
computer as yesterday with my 96 MB Windows98 (First Edition, Servicepack 1).

Comment 6

15 years ago
REGRESSED between 
Mozilla  BuildID 2003061204 (working) 
Firebird BuildID 20030614   (failing)
Mozilla  BuildID 2003061608 (failing)

Comment 7

15 years ago
Maybe regression caused by Windows Bug 203847  	Make sure that dragged file is
deleted from intermediate location 	

was checked in 06/13/2003 13:38, a day after last working mozilla, a day before
failing Firebird.

Comment 8

15 years ago
setting Component and confirming
Assignee: general → blake
Status: UNCONFIRMED → NEW
Component: Browser-General → XP Apps: Drag and Drop
Ever confirmed: true
QA Contact: general → pmac

Comment 9

14 years ago
Ummm... on Win2000 this works flawlessly with Mozilla 1.6.

Nina, Hermann, can you re-test this?

Comment 10

14 years ago
tested not working:
Win98SE (XP1600, 512MB, lots of space on disk, nvidia nForce integrated grafics)
Win98 SP1 (Celeron 333, 96 MB, 8 MB noname graficscard SiS6326)

Load http://www.google.de/, logo is http://www.google.de/intl/de_de/images/logo.gif
Resize Mozilla, so you can see a folder in explorer.
Drag logo into explorer, when I drop it, i get an error message from Windows:

Fehler beim Verschieben der Datei
Datei kann nicht verschoben werden: Dateisystemfehler (1026).

my translation:
Error moving file
File can´t be moved: file system error (1026).

The Win98SE computer has 1 disk with one partition only, 30 GB.
the Win98 computer has a 10 GB and a 4 GB harddisk, with multiple partions on
each one, cache, temp, swapfile on different partitions, bootloader, linux.

Comment 11

14 years ago
Hermann, if possible, you could use the "Filemon" tool by Sysinternals to find
out which files are accessed and which errors occur.
Assignee: bross2 → nobody
QA Contact: pmac

Comment 12

10 years ago
fixed by bug 203307 (on trunk)?

Comment 13

9 years ago
WFm Mozilla/5.0 (Windows; U; Windows NT 6.0; en-US; rv:1.9.1b2) Gecko/20081125 Firefox/3.1b2
Status: NEW → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.