awk required. But with only gawk installed get confusing error message

RESOLVED FIXED in mozilla1.6alpha

Status

SeaMonkey
Build Config
RESOLVED FIXED
15 years ago
13 years ago

People

(Reporter: John Bandhauer, Assigned: (default assignee for unassigned bugs. does not receive bugmail))

Tracking

Trunk
mozilla1.6alpha
x86
Windows XP

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

15 years ago
The build system now uses awk during compiler detection. The build instructions
page for Win32 talks about the cygwin gawk being required. But (at least for the
cygwin version I have) this does not result in anything on the path being called
"awk".

Fo me, this causes a fresh pull and build (of both trunk and 1.5 branch) to fail
with the misleading error:

...
checking for ar... ar
checking for ld... link
checking for strip... strip
checking for windres... windres
/cygdrive/c/Program: not found
checking for midl... midl
awk: not found
awk: not found
configure: error: This version of the MSVC compiler, 12.00.8804 for 80x86 , is u
nsupported.
*** Fix above errors and then restart with "make -f client.mk build"
make: *** [/cygdrive/x/trunk_debug/Makefile] Error 1


A look at comfigure[.in] shows that the problem is really the lack of awk
causing the compiler version check to fail for what is actually a supported
compiler version. I'd think this would confuse others.

I hacked this on my machine by just copying gawk.exe to awk.exe and getting on
with my life.

But, don't other people trip over this? If this is not normally a problem for
people, then someone ought to at least note the problem and the (recommended)
solution in the build docs.

Thanks!
I have "awk.exe" in my cygwin folder (awk is only 19byte and ghawk is 240k)

Comment 2

15 years ago
How old is your cygwin install?  On my w2k boxes, awk.exe is a symlink to
gawk.exe .  I think it's always been that way but I'm not sure.  I think this
can be solved by moving the AWK check up for win32.
(Reporter)

Comment 3

15 years ago
OK. I get it now. My cygwin install (actually I tried two) had been copied from
another machine. The windows explorer and the cygwin shell and tools see and use
the symlinked awk.exe on the original machine just fine. XP's cmd and 4NT shell
(and built-in tools like copy) do not see the symlink at all. So, the symlink
had not been copied onto my new target machine.

So, I'm thinking this is probably a rare enough problem that you could just
close the bug. Or you could exlicitly use gawk in the Win32 case, or just
document the cause of the error in case anyone else trips over it. Certainly
your call.

Comment 4

15 years ago
I just moved the AWK check and used $AWK instead of awk.

Checking in configure;
/cvsroot/mozilla/configure,v  <--  configure
new revision: 1.1234; previous revision: 1.1233
done
Checking in configure.in;
/cvsroot/mozilla/configure.in,v  <--  configure.in
new revision: 1.1278; previous revision: 1.1277
done
Status: NEW → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla1.6alpha
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.