Note: There are a few cases of duplicates in user autocompletion which are being worked on.

Firebird/Mozilla does not crash (or quit) gracefully

RESOLVED DUPLICATE of bug 36810

Status

SeaMonkey
Tabbed Browser
--
enhancement
RESOLVED DUPLICATE of bug 36810
14 years ago
9 years ago

People

(Reporter: Joel Eidsath, Assigned: jag (Peter Annema))

Tracking

Trunk
x86
Windows XP

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

14 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.5b) Gecko/20030905 Firebird/0.6.1+
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.5b) Gecko/20030905 Firebird/0.6.1+

When Firebird/Mozilla crashes, the set of tabs being viewed is lost forever. 
Proper functioning (like Opera) would make sure that the list of open tabs is
always saved to disk.  That way, all pages could be restored after a crash. 
This functionality would also be useful in cases where a user is forced to quit
Firebird for other reasons.

Reproducible: Always

Steps to Reproduce:
1.  Crash (or quit) Firebird (however you choose)
2.  Restart the program
3.  Note that all open tabs are lost

Actual Results:  
Firebird opened up to my homepage

Expected Results:  
I should have been given the option of going back to where I was before the crash.

This problem was less important before tabbed browsing (a user could go to the
'Go' menu and restore the last page).  With numerous open tabs, this becomes a
major problem.

*** This bug has been marked as a duplicate of 36810 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → DUPLICATE
Product: Core → SeaMonkey
You need to log in before you can comment on or make changes to this bug.