Mozilla hangs with multiple mailboxes if non-primary is IMAP SSL

RESOLVED FIXED

Status

MailNews Core
Networking: IMAP
--
critical
RESOLVED FIXED
15 years ago
10 years ago

People

(Reporter: Dan Rich, Assigned: Bienvenu)

Tracking

({hang})

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(2 attachments)

(Reporter)

Description

15 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.5b) Gecko/20030827
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.5b) Gecko/20030827

I read my home e-mail from work via. an SSH tunnel to an IMAP/SSL server (UW
2002d).  My primary e-mail account is to our local imap server.

If I start the Mozilla mail client while the ssh tunnel is running Mozilla will
hang.  If I start the mail client (it complains about not being able to contact
localhost as expected) and then start the tunnel things work fine.

Reproducible: Always

Steps to Reproduce:
1.
2.
3.
(Reporter)

Comment 1

15 years ago
I should add, this is only and issue with 1.5b, it worked fine in 1.4 and earlier.
(Assignee)

Comment 2

15 years ago
cc'ing darin.
Status: UNCONFIRMED → NEW
Ever confirmed: true

Updated

15 years ago
Keywords: hang
(Reporter)

Comment 3

15 years ago
Just a little bit of additional info, this still fails in 1.5RC1.  Also, when I
look at the logs on my imap server I see an SSL connection but no username.

Here is my initial connection (when Mozilla hangs) -- the "end of file" is from
my killing mozilla:
Sep 18 09:51:34 morpheus imapd[17256]: imaps SSL service init from 127.0.0.1
Sep 18 09:53:00 morpheus imapd[17256]: Command stream end of file, while reading
line user=??? host=localhost [127.0.0.1]

And here is the connection after I kill my ssh tunnel, start the mail reader,
and then start the tunnel:
Sep 18 09:58:14 morpheus imapd[17641]: imaps SSL service init from 127.0.0.1
Sep 18 09:58:17 morpheus imapd[17641]: Authenticated user=drich host=localhost
[127.0.0.1]

(Assignee)

Comment 4

15 years ago
can we get a client-side imap protocol log? It might be empty, but maybe it will
tell us something? Here's how to get a client-side log:

http://www.mozilla.org/quality/mailnews/mail-troubleshoot.html#imap
(Reporter)

Comment 5

15 years ago
Created attachment 131690 [details]
imap client log when mozilla hangs

Here is the client-side log generated when the ssh tunnel is up and mozilla
hangs on startup of the mail client.
(Reporter)

Comment 6

15 years ago
Created attachment 131691 [details]
Working client-side imap log

Here is a client-side log from a working mozilla.  This was created by killing
my ssh tunnel, starting mozilla and the mail client, starting the ssh tunnel,
and then checking a mailbox via. the tunnel.  Connections to localhost are via.
the tunnel, and connections to imap.pdi.com are my non-SSL primary mailboxes.

Log has been edited to fit into attachment limitations
(Assignee)

Comment 7

15 years ago
hmm, it looks like the connection gets established and torn down right away,
without ever even getting a greeting from the server, as if the SSL handshake
didn't work or something...

Could you try a 1.6 build from yesterday or today just for fun? I doubt it will
make any difference but I did change the imap protocol code to use blocking reads
(Assignee)

Comment 8

15 years ago
any luck with a recent 1.6 build?
(Reporter)

Comment 9

15 years ago
Sorry it's taken me so long, I got tied up with that work thing. :)

I tried the latest snapshot this morning, it hangs in the same way as 1.5.

Comment 10

15 years ago
I'm having the same problem, though I don't connect through ssh, but directly
using IMAP SSL.  (Don't know if it helps or not, but...) renaming my .mozilla
directory to .mozilla.bak and restarting mozilla made the hang go away.

Comment 11

15 years ago
See also bug 223356 - could they be related?
(Assignee)

Comment 12

15 years ago
can you try another nightly build from today and see if it's fixed? I fixed a
problem with getting the remembered password from the password manager that
seemed to only affect multiple SSL accounts (I don't think it would cause a
hang, but it's worth trying today's build)
(Reporter)

Comment 13

15 years ago
I don't know if that fix was it, but something in the latest nightly fixed the
problem!  The bug is gone in the latest nightly.
(Assignee)

Comment 14

15 years ago
thx, marking fixed
Status: NEW → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → FIXED
Product: MailNews → Core
Product: Core → MailNews Core
You need to log in before you can comment on or make changes to this bug.