Closed Bug 219086 Opened 18 years ago Closed 18 years ago

use method="post" on the "My Votes" page to be more robust

Categories

(Bugzilla :: Bugzilla-General, enhancement)

x86
Linux
enhancement
Not set
normal

Tracking

()

RESOLVED FIXED
Bugzilla 2.18

People

(Reporter: daniel.naber, Assigned: justdave)

Details

Attachments

(1 file)

User-Agent:       Mozilla/5.0 (compatible; Konqueror/3.1; Linux)
Build Identifier: 

The "My votes" page has no method="..." attribute in its <form> tag, so it defaults to "get". I 
think it should be made method="post" to be more robust even for very long lists of votes. As 
the length of the query url might be limited somewhere in browsers or proxies, "post" should 
be more robust than "get". 
 
Actually a user of the KDE bug tracking system complained that some of this votes were lost. 
I don't know, but the missing method="post" could be the reason (the user said he had very 
many votes). 
 

Reproducible: Didn't try

Steps to Reproduce:
1.
2.
3.
Sounds like a logical thing to do.
Status: UNCONFIRMED → ASSIGNED
Ever confirmed: true
Attachment #131375 - Flags: review?(kiko)
Target Milestone: --- → Bugzilla 2.18
Comment on attachment 131375 [details] [diff] [review]
Patch

sure
Attachment #131375 - Flags: review?(kiko) → review+
Looks ok to me.
Checking in template/en/default/bug/votes/list-for-user.html.tmpl;
/cvsroot/mozilla/webtools/bugzilla/template/en/default/bug/votes/list-for-user.html.tmpl,v
 <--  list-for-user.html.tmpl
new revision: 1.11; previous revision: 1.10
done
Status: ASSIGNED → RESOLVED
Closed: 18 years ago
Flags: approval+
Resolution: --- → FIXED
QA Contact: matty_is_a_geek → default-qa
You need to log in before you can comment on or make changes to this bug.